Every CVE Search/ Get API key

CVE-2023-5561

WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

5.3 MediumPublic exploitFix available

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

4.33%Up 4.3 points since Oct 17, 2023
90%50%10%1%

What each source reports

NVD Score used 5.3

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
CVE-2023-5561
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
CVE List 5.3

WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
CVE-2023-5561
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
EUVDEUVD-2023-57861 5.3

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
EUVD-2023-57861
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-x7w6-3cp2-qjcv 5.3

The Popup Builder WordPress plugin through 4.1.15 does not sanitise and escape some of its...

The Popup Builder WordPress plugin through 4.1.15 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Record
GHSA-x7w6-3cp2-qjcv
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 5.3

WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
CVE-2023-5561
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2023-5561 5.3

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
DEBIAN-CVE-2023-5561
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2023-5561 5.3

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
UBUNTU-CVE-2023-5561
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVBIT-wordpress-2023-5561 No score

WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
BIT-wordpress-2023-5561
Updated
2026-11-02
OSVBIT-wordpress-multisite-2023-5561 No score

WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Record
BIT-wordpress-multisite-2023-5561
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Bitnami
4.7.0 up to 4.7.27, 4.8.0 up to 4.8.23, 4.9.0 up to 4.9.24, 5.0.0 up to 5.0.20, 5.1.0 up to 5.1.17, 5.2.0 up to 5.2.19, 5.3.0 up to 5.3.16, 5.4.0 up to 5.4.14, 5.5.0 up to 5.5.13, 5.6.0 up to 5.6.12, 5.7.0 up to 5.7.10, 5.8.0 up to 5.8.8, 5.9.0 up to 5.9.8, 6.0.0 up to 6.0.6, 6.1.0 up to 6.1.4, 6.2.0 up to 6.2.3, 6.3.0 up to 6.3.2
4.7.274.8.234.9.245.0.205.1.175.2.195.3.165.4.145.5.135.6.125.7.105.8.85.9.86.0.66.1.46.2.36.3.2
wordpress-multisite
Bitnami
4.7.0 up to 4.7.27, 4.8.0 up to 4.8.23, 4.9.0 up to 4.9.24, 5.0.0 up to 5.0.20, 5.1.0 up to 5.1.17, 5.2.0 up to 5.2.19, 5.3.0 up to 5.3.16, 5.4.0 up to 5.4.14, 5.5.0 up to 5.5.13, 5.6.0 up to 5.6.12, 5.7.0 up to 5.7.10, 5.8.0 up to 5.8.8, 5.9.0 up to 5.9.8, 6.0.0 up to 6.0.6, 6.1.0 up to 6.1.4, 6.2.0 up to 6.2.3, 6.3.0 up to 6.3.2
4.7.274.8.234.9.245.0.205.1.175.2.195.3.165.4.145.5.135.6.125.7.105.8.85.9.86.0.66.1.46.2.36.3.2
wordpress
Debian:12
before 6.1.6+dfsg1-0+deb12u1, plus listed versions
6.1.1+dfsg1-1
6.1.6+dfsg1-0+deb12u1
wordpress
Debian:13
before 6.3.2+dfsg1-1
6.3.2+dfsg1-1
wordpress
Debian:14
before 6.3.2+dfsg1-1
6.3.2+dfsg1-1
wordpress
Debian:10
From an advisory covering 2 CVEs
before 5.0.20+dfsg1-0+deb10u1, plus listed versions
5.0.10+dfsg1-0+deb10u15.0.11+dfsg1-0+deb10u15.0.12+dfsg1-0+deb10u15.0.14+dfsg1-0+deb10u15.0.15+dfsg1-0+deb10u1
Show 6 moreShow less
5.0.17+dfsg1-0+deb10u15.0.18+dfsg1-0+deb10u15.0.19+dfsg1-0+deb10u15.0.4+dfsg1-15.0.4+dfsg1-1+deb10u15.0.4+dfsg1-1+deb10u2
5.0.20+dfsg1-0+deb10u1
wordpress
Debian:11
From an advisory covering 4 CVEs
before 5.7.11+dfsg1-0+deb11u1, plus listed versions
5.7.1+dfsg1-25.7.3+dfsg1-0+deb11u15.7.5+dfsg1-0+deb11u15.7.8+dfsg1-0+deb11u15.7.8+dfsg1-0+deb11u2
5.7.11+dfsg1-0+deb11u1
wordpress
Debian:12
From an advisory covering 4 CVEs
before 6.1.6+dfsg1-0+deb12u1, plus listed versions
6.1.1+dfsg1-1
6.1.6+dfsg1-0+deb12u1
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known
wordpress
Ubuntu:18.04:LTS
All versions, plus listed versions
4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1
None known
wordpress
Ubuntu:20.04:LTS
All versions, plus listed versions
5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1
None known
wordpress
Ubuntu:22.04:LTS
All versions, plus listed versions
5.7.1+dfsg1-2ubuntu15.8.1+dfsg1-2ubuntu15.8.2+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu1.1
None known
wordpress
Ubuntu:24.04:LTS
All versions, plus listed versions
6.2+dfsg1-1ubuntu16.4.3+dfsg1-1ubuntu1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubpog007/CVE-2023-5561-PoC2023-12-13
PoC in GitHubrootxsushant/CVE-2023-5561-POC-Updated2025-04-01
PoC in GitHubdthkhang/CVE-2023-5561-PoC2025-07-01
NucleiWordPress Core - Post Author Email Disclosure

History

History
RecordedChangedSources
affected, exploits, facts
first indexedCVE List, EUVD, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-5561 is a medium vulnerability (CVSS 5.3) in Wordpress, published October 16, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.33%, the 91st percentile. Fixed in wordpress 4.7.27.

References

Show 4 moreShow less
MoveEnter Open