CVE-2023-5568
Samba: heap buffer overflow with freshness tokens in the heimdal kdc
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.9
Samba: heap buffer overflow with freshness tokens in the heimdal kdc
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
CVE-2023-5568- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2023-57867
5.9
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
EUVD-2023-57867- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x3c8-vcr7-5m4v
5.9
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated...
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
GHSA-x3c8-vcr7-5m4v- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H - Weakness
- CWE-122, CWE-787
- Updated
- 2026-11-02
NVD
5.9
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
CVE-2023-5568- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-122, CWE-787
- Updated
- 2026-11-02
OSVAZL-31745
6.5
CVE-2023-5568 affecting package samba 4.12.5-7
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
AZL-31745- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-37029
6.5
CVE-2023-5568 affecting package samba 4.18.3-2
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
AZL-37029- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-05
Show 5 moreShow less
OSV
5.9
Samba: heap buffer overflow with freshness tokens in the heimdal kdc
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
CVE-2023-5568- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-5568
6.5
A heap-based Buffer Overflow flaw was discovered in Samba. It could allow a remote, authenticated attacker to exploit this vulnerability to cause a denial of service.
- Record
DEBIAN-CVE-2023-5568- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13345-1 No score
ctdb-4.19.2+git.322.7e9201cef5-1.1 on GA media
These are all security issues fixed in the ctdb-4.19.2+git.322.7e9201cef5-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13345-1- Updated
- 2026-11-02
OSVROOT-OS-ALPINE-318-CVE-2023-5568 No score
CVE-2023-5568 in samba - Patched by Root
Root has patched CVE-2023-5568 in the samba package for Root:Alpine:3.18. Multiple fixed versions available.
- Record
ROOT-OS-ALPINE-318-CVE-2023-5568- Updated
- 2026-11-02
OSVROOT-OS-ALPINE-319-CVE-2023-5568 No score
CVE-2023-5568 in samba - Patched by Root
Root has patched CVE-2023-5568 in the samba package for Root:Alpine:3.19. Multiple fixed versions available.
- Record
ROOT-OS-ALPINE-319-CVE-2023-5568- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sambaAzure Linux:2 |
through 4.12.5-7 | None known |
sambaAzure Linux:3 |
through 4.18.3-2 | None known |
sambaDebian:13 |
before 2:4.19.2+dfsg-1 | 2:4.19.2+dfsg-1 |
sambaDebian:14 |
before 2:4.19.2+dfsg-1 | 2:4.19.2+dfsg-1 |
sambaRoot:Alpine:3.18 |
before 4.18.11-r00071 | 4.18.11-r000714.18.11-r000724.18.11-r000734.18.11-r00074 |
rootio-sambaRoot:Alpine:3.18 |
before 4.18.11-r00071 | 4.18.11-r000714.18.11-r000724.18.11-r000734.18.11-r00074 |
sambaRoot:Alpine:3.19 |
before 4.18.11-r00071 | 4.18.11-r000714.18.11-r000734.18.11-r000724.18.11-r00074 |
rootio-sambaRoot:Alpine:3.19 |
before 4.18.11-r00071 | 4.18.11-r000714.18.11-r000734.18.11-r000724.18.11-r00074 |
sambaopenSUSE:Tumbleweed |
before 4.19.2+git.322.7e9201cef5-1.1 | 4.19.2+git.322.7e9201cef5-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-5568 is a medium vulnerability (CVSS 5.9) in Samba, published October 24, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in samba 2:4.19.2+dfsg-1.