Every CVE Search/ Get API key

CVE-2023-7158

MicroPython objslice.c slice_indices heap-based overflow

7.3 HighFix available

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

1.23%Up 1.2 points since Dec 29, 2023
90%50%10%1%

What each source reports

CVE List Score used 7.3

MicroPython objslice.c slice_indices heap-based overflow

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
CVE-2023-7158
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2023-59339 7.3

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
EUVD-2023-59339
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-x33q-m927-7mq6 7.3

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical....

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
GHSA-x33q-m927-7mq6
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-122, CWE-787
Updated
2026-11-02
NVD 7.3

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
CVE-2023-7158
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-122, CWE-787
Updated
2026-11-02
OSV 7.3

MicroPython objslice.c slice_indices heap-based overflow

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
CVE-2023-7158
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-122
Updated
2026-11-02
OSVUBUNTU-CVE-2023-7158 7.3

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Record
UBUNTU-CVE-2023-7158
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13566-1 No score

micropython-1.22.0-1.1 on GA media

These are all security issues fixed in the micropython-1.22.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13566-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
giac
Ubuntu:18.04:LTS
All versions, plus listed versions
1.2.3.57+dfsg1-2build11.2.3.57+dfsg1-2build21.2.3.57+dfsg1-2build3
None known
giac
Ubuntu:20.04:LTS
All versions, plus listed versions
1.4.9.69+dfsg1-2build11.5.0.85+dfsg1-21.5.0.85+dfsg1-3
None known
giac
Ubuntu:22.04:LTS
All versions, plus listed versions
1.6.0.41+dfsg1-11.7.0.39+dfsg2-1build11.7.0.39+dfsg2-1build2
None known
giac
Ubuntu:24.04:LTS
All versions, plus listed versions
1.9.0.35+dfsg2-1.11.9.0.59+dfsg2-11.9.0.69+dfsg2-11.9.0.93+dfsg2-2
None known
giac
Ubuntu:25.10
All versions, plus listed versions
1.9.0.93+dfsg2-3build1
None known
giac
Ubuntu:26.10
All versions, plus listed versions
1.9.0.93+dfsg2-3build21.9.0.93+dfsg2-4
None known
giac
Ubuntu:26.04:LTS
All versions, plus listed versions
1.9.0.93+dfsg2-3build11.9.0.93+dfsg2-3build2
None known
micropython
openSUSE:Tumbleweed
before 1.22.0-1.1
1.22.0-1.1

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-7158 is a high vulnerability (CVSS 7.3) in Micropython, published December 29, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in micropython 1.22.0-1.1.

References

Show 9 moreShow less
MoveEnter Open