Every CVE Search/ Get API key

CVE-2024-0321

Stack-based Buffer Overflow in gpac/gpac

4.0 MediumFix available

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

1.04%Up 1.0 points since Jan 18, 2024
90%50%10%1%

What each source reports

CVE List Score used 4.0

Stack-based Buffer Overflow in gpac/gpac

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
CVE-2024-0321
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2024-16117 4.0

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
EUVD-2024-16117
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-mf6c-8r47-23j5 4.0

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
GHSA-mf6c-8r47-23j5
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-121, CWE-787
Updated
2026-11-02
NVD 9.8

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
CVE-2024-0321
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-121, CWE-787
Updated
2026-11-02
OSV 4.0

Stack-based Buffer Overflow in gpac/gpac

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
CVE-2024-0321
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-121
Updated
2026-11-02
OSVDEBIAN-CVE-2024-0321 9.8

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
DEBIAN-CVE-2024-0321
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-0321 9.8

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.

Record
UBUNTU-CVE-2024-0321
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVMGASA-2025-0090 No score

Updated gpac packages fix security vulnerabilities

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2. (CVE-2023-5520) Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV. (CVE-2024-0321) Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.3-DEV. (CVE-2024-0322)

Record
MGASA-2025-0090
Updated
2026-11-02
OSVUSN-7320-1 No score

gpac vulnerabilities

It was discovered that the GPAC MP4Box utility incorrectly handled certain AC3 files, which could lead to an out-of-bounds read. A remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service (system crash). This issue only affected Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2023-5520, CVE-2024-0322)

It was discovered that the GPAC MP4Box utility incorrectly handled certain malformed text files. If a user or automated system using MP4Box were tricked into opening a specially crafted RST file, an attacker could use this issue to cause a denial of service (system crash) or execute arbitrary code. (CVE-2024-0321)

Record
USN-7320-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpac
Debian:11
All versions, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-4+deb11u11.0.1+dfsg1-4+deb11u21.0.1+dfsg1-4+deb11u31.0.1+dfsg1-5
Show 8 moreShow less
2.0.0+dfsg1-12.0.0+dfsg1-22.0.0+dfsg1-42.2.1+dfsg1-12.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1~exp1
None known
gpac
Mageia:9
From an advisory covering 3 CVEs
before 2.2.1-1.2.mga9.tainted
2.2.1-1.2.mga9.tainted
gpac
Ubuntu:Pro:14.04:LTS
before 0.5.0+svn4288~dfsg1-4ubuntu1+esm2, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm1
0.5.0+svn4288~dfsg1-4ubuntu1+esm2
gpac
Ubuntu:Pro:16.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
gpac
Ubuntu:Pro:18.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
gpac
Ubuntu:Pro:20.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-5
0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
gpac
Ubuntu:Pro:22.04:LTS
before 2.0.0+dfsg1-2ubuntu0.1~esm2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-2
2.0.0+dfsg1-2ubuntu0.1~esm2
gpac
Ubuntu:Pro:24.04:LTS
before 2.2.1+dfsg1-3.1ubuntu0.1~esm2, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build2
2.2.1+dfsg1-3.1ubuntu0.1~esm2
gpac
Ubuntu:Pro:14.04:LTS
From an advisory covering 3 CVEs
before 0.5.0+svn4288~dfsg1-4ubuntu1+esm2, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm1
0.5.0+svn4288~dfsg1-4ubuntu1+esm2
gpac
Ubuntu:Pro:16.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
Show 4 moreShow less
Affected packages
PackageAffectedFixed
gpac
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
gpac
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-5
0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
gpac
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 2.0.0+dfsg1-2ubuntu0.1~esm2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-2
2.0.0+dfsg1-2ubuntu0.1~esm2
gpac
Ubuntu:Pro:24.04:LTS
From an advisory covering 3 CVEs
before 2.2.1+dfsg1-3.1ubuntu0.1~esm2, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build2
2.2.1+dfsg1-3.1ubuntu0.1~esm2

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-0321 is a medium vulnerability (CVSS 4.0) in Gpac, published January 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in gpac 0.5.0+svn4288~dfsg1-4ubuntu1+esm2.

References

Show 7 moreShow less
MoveEnter Open