Every CVE Search/ Get API key

CVE-2024-0964

LFI in Gradio

7.5 HighFix available

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.95%Up 0.9 points since Feb 8, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

LFI in Gradio

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
CVE-2024-0964
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2024-0623 7.5

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
EUVD-2024-0623
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-f3h9-8phc-6gvh 7.5

Gradio Path Traversal vulnerability

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
GHSA-f3h9-8phc-6gvh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
NVD 9.4

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
CVE-2024-0964
CVSS 3.1
9.4 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

LFI in Gradio

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
CVE-2024-0964
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-f3h9-8phc-6gvh 7.5

Gradio Path Traversal vulnerability

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
GHSA-f3h9-8phc-6gvh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVPYSEC-2024-261 9.4

A local file include could be remotely triggered in Gradio due to a vulnerable user-supplied JSON value in an API request.

Record
PYSEC-2024-261
CVSS 3.1
9.4 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gradio
PyPI
before 4.9.0
4.9.0
gradio
PyPI
before 4.9.0, plus listed versions
0.1.00.1.10.1.20.1.30.1.4
Show 45 moreShow less
0.1.50.1.60.1.70.1.80.1.90.2.00.2.10.3.00.3.10.3.20.3.30.3.40.3.50.4.00.4.10.4.20.4.40.5.00.7.00.7.10.7.20.7.30.7.40.7.50.7.60.7.70.7.80.8.00.8.10.9.00.9.10.9.20.9.30.9.40.9.50.9.60.9.70.9.80.9.9.20.9.9.30.9.9.50.9.9.60.9.9.70.9.9.80.9.9.9
4.9.0
gradio
PyPI
Not stated
Not evaluated

Not evaluated means the source gave git commits or a range we can't read, so we can't tell which releases are affected. A fixed version beside it is the source’s own claim.

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-0964 is a high vulnerability (CVSS 7.5) in Gradio App Gradio, published February 5, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.95%, the 61st percentile. Fixed in gradio 4.9.0.

References

This page doesn't list everything

Left out here: 445 versions. The JSON record has them.

MoveEnter Open