Every CVE Search/ Get API key

CVE-2024-10229

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a...

8.1 HighFix available

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.54%Up 0.5 points since Oct 23, 2024
90%50%10%1%

What each source reports

NVD Score used 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
CVE-2024-10229
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
CVE List 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
CVE-2024-10229
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
EUVDEUVD-2024-32988 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
EUVD-2024-32988
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-3hjp-j522-245f 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a...

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
GHSA-3hjp-j522-245f
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVALPINE-CVE-2024-10229 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
ALPINE-CVE-2024-10229
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-03
OSV 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
CVE-2024-10229
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2024-10229 8.1

Inappropriate implementation in Extensions in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to bypass site isolation via a crafted Chrome Extension. (Chromium security severity: High)

Record
DEBIAN-CVE-2024-10229
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:0341-1 No score

Security update for chromium

This update for chromium fixes the following issues:

Chromium 130.0.6723.69 (boo#1232060)

  • CVE-2024-10229: Inappropriate implementation in Extensions
  • CVE-2024-10230: Type Confusion in V8
  • CVE-2024-10231: Type Confusion in V8
Record
openSUSE-SU-2024:0341-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14441-1 No score

chromedriver-130.0.6723.69-1.1 on GA media

These are all security issues fixed in the chromedriver-130.0.6723.69-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14441-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15531-1 No score

libQt5Pdf5-5.15.19-1.1 on GA media

These are all security issues fixed in the libQt5Pdf5-5.15.19-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15531-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt5-qtwebengine
Alpine:v3.20
before 5.15.16-r14
5.15.16-r14
qt5-qtwebengine
Alpine:v3.21
before 5.15.17-r5
5.15.17-r5
qt5-qtwebengine
Alpine:v3.22
before 5.15.17-r5
5.15.17-r5
qt5-qtwebengine
Alpine:v3.23
before 5.15.17-r5
5.15.17-r5
qt6-qtwebengine
Alpine:v3.21
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.22
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.23
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.24
before 6.7.2-r6
6.7.2-r6
chromium
Debian:12
before 130.0.6723.69-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
130.0.6723.69-1~deb12u1
chromium
Debian:13
before 130.0.6723.69-1
130.0.6723.69-1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
chromium
Debian:14
before 130.0.6723.69-1
130.0.6723.69-1
chromium
SUSE:Package Hub 15 SP5
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
SUSE:Package Hub 15 SP6
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
openSUSE:Leap 15.5
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
openSUSE:Leap 15.6
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
openSUSE:Tumbleweed
before 130.0.6723.69-1.1
130.0.6723.69-1.1
libqt5-qtwebengine
openSUSE:Tumbleweed
before 5.15.19-1.1
5.15.19-1.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-10229 is a high vulnerability (CVSS 8.1) in Google Chrome, published October 22, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in qt5-qtwebengine 5.15.16-r14.

References

Show 21 moreShow less
This page doesn't list everything

Left out here: 114 versions. The JSON record has them.

MoveEnter Open