Every CVE Search/ Get API key

CVE-2024-10231

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to...

8.8 HighFix available

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.52%Up 0.5 points since Oct 23, 2024
90%50%10%1%

What each source reports

NVD Score used 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-10231
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
CVE List 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-10231
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843, CWE-843
Updated
2026-11-02
EUVDEUVD-2024-32990 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
EUVD-2024-32990
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-3wfx-mj93-vf8v 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to...

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
GHSA-3wfx-mj93-vf8v
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
OSVALPINE-CVE-2024-10231 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
ALPINE-CVE-2024-10231
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-10231
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2024-10231 8.8

Type Confusion in V8 in Google Chrome prior to 130.0.6723.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
DEBIAN-CVE-2024-10231
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:0341-1 No score

Security update for chromium

This update for chromium fixes the following issues:

Chromium 130.0.6723.69 (boo#1232060)

  • CVE-2024-10229: Inappropriate implementation in Extensions
  • CVE-2024-10230: Type Confusion in V8
  • CVE-2024-10231: Type Confusion in V8
Record
openSUSE-SU-2024:0341-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14441-1 No score

chromedriver-130.0.6723.69-1.1 on GA media

These are all security issues fixed in the chromedriver-130.0.6723.69-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14441-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14494-1 No score

nodejs-electron-31.7.4-1.1 on GA media

These are all security issues fixed in the nodejs-electron-31.7.4-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14494-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt6-qtwebengine
Alpine:v3.21
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.22
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.23
before 6.7.2-r6
6.7.2-r6
qt6-qtwebengine
Alpine:v3.24
before 6.7.2-r6
6.7.2-r6
chromium
Debian:12
before 130.0.6723.69-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
130.0.6723.69-1~deb12u1
chromium
Debian:13
before 130.0.6723.69-1
130.0.6723.69-1
chromium
Debian:14
before 130.0.6723.69-1
130.0.6723.69-1
chromium
Debian:12
From an advisory covering 3 CVEs
before 130.0.6723.69-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
130.0.6723.69-1~deb12u1
chromium
SUSE:Package Hub 15 SP5
From an advisory covering 3 CVEs
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
SUSE:Package Hub 15 SP6
From an advisory covering 3 CVEs
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
chromium
openSUSE:Leap 15.5
From an advisory covering 3 CVEs
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
openSUSE:Leap 15.6
From an advisory covering 3 CVEs
before 130.0.6723.69-bp156.2.44.1
130.0.6723.69-bp156.2.44.1
chromium
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 130.0.6723.69-1.1
130.0.6723.69-1.1
nodejs-electron
openSUSE:Tumbleweed
before 31.7.4-1.1
31.7.4-1.1

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-10231 is a high vulnerability (CVSS 8.8) in Google Chrome, published October 22, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in qt6-qtwebengine 6.7.2-r6.

References

Show 7 moreShow less
This page doesn't list everything

Left out here: 228 versions. The JSON record has them.

MoveEnter Open