Every CVE Search/ Get API key

CVE-2024-10918

Stack-based Buffer Overflow in libmodbus library

4.8 MediumFix available

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
Low

Exploit likelihood

0.56%Up 0.5 points since Feb 28, 2025
90%50%10%1%

What each source reports

CVE List Score used 4.8

Stack-based Buffer Overflow in libmodbus library

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
CVE-2024-10918
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2024-53894 4.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
EUVD-2024-53894
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-96xh-5wq4-m4cc 4.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer...

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
GHSA-96xh-5wq4-m4cc
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-121, CWE-787
Updated
2026-11-02
NVD 4.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
CVE-2024-10918
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-121, CWE-787
Updated
2026-11-02
OSV 4.8

Stack-based Buffer Overflow in libmodbus library

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
CVE-2024-10918
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-121
Updated
2026-11-02
OSVDEBIAN-CVE-2024-10918 9.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
DEBIAN-CVE-2024-10918
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVJLSEC-2026-1252 9.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer...

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
JLSEC-2026-1252
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-10918 4.8

Stack-based Buffer Overflow vulnerability in libmodbus v3.1.10 allows to overflow the buffer allocated for the Modbus response if the function tries to reply to a Modbus request with an unexpected length.

Record
UBUNTU-CVE-2024-10918
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libmodbus
Debian:12
before 3.1.6-2.1+deb12u1, plus listed versions
3.1.6-2.1
3.1.6-2.1+deb12u1
libmodbus
Debian:13
before 3.1.11-1
3.1.11-1
libmodbus
Debian:14
before 3.1.11-1
3.1.11-1
libmodbus
Debian:11
From an advisory covering 5 CVEs
before 3.1.6-2+deb11u1, plus listed versions
3.1.6-2
3.1.6-2+deb11u1
LibModbus_jll
Julia
3.1.10+0 up to 3.1.12+0
3.1.12+0
libmodbus
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
3.0.4-13.0.5-13.0.5-1ubuntu0.1~esm1
None known
libmodbus
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.0.6-13.0.6-1ubuntu0.1~esm1
None known
libmodbus
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.6-23.0.6-2ubuntu0.1~esm13.0.6-2+deb9u1build0.18.04.1
None known
libmodbus
Ubuntu:20.04:LTS
All versions, plus listed versions
3.1.6-13.1.6-2
None known
libmodbus
Ubuntu:22.04:LTS
All versions, plus listed versions
3.1.6-2
None known
libmodbus
Ubuntu:24.04:LTS
All versions, plus listed versions
3.1.6-2.13.1.10-1ubuntu1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-10918 is a medium vulnerability (CVSS 4.8) in Libmodbus, published February 27, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in libmodbus 3.1.6-2.1+deb12u1.

References

Show 8 moreShow less
MoveEnter Open