Every CVE Search/ Get API key

CVE-2024-10975

Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

7.7 HighFix available

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.45%Up 0.4 points since Nov 8, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.7

Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
CVE-2024-10975
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2024-3181 7.7

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
EUVD-2024-3181
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-2w5v-x29g-jw7j 6.3

Hashicorp Nomad Incorrect Authorization vulnerability

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
GHSA-2w5v-x29g-jw7j
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 7.7

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
CVE-2024-10975
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 7.7

Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
CVE-2024-10975
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVGHSA-2w5v-x29g-jw7j 6.3

Hashicorp Nomad Incorrect Authorization vulnerability

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
GHSA-2w5v-x29g-jw7j
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2024-10975 7.7

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Record
UBUNTU-CVE-2024-10975
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVGO-2024-3262 No score

Hashicorp Nomad Incorrect Authorization vulnerability in github.com/hashicorp/nomad

Hashicorp Nomad Incorrect Authorization vulnerability in github.com/hashicorp/nomad

Record
GO-2024-3262
Updated
2026-11-02
OSVopenSUSE-SU-2024:14482-1 No score

govulncheck-vulndb-0.0.20241108T172500-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20241108T172500-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14482-1
Updated
2026-11-02
OSVSUSE-SU-2024:4042-1 No score

Security update for govulncheck-vulndb

This update for govulncheck-vulndb fixes the following issues:

  • Update to version 0.0.20241112T145010 2024-11-12T14:50:10Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:

    • GO-2024-3250 CVE-2024-51744 GHSA-29wx-vh33-7x7r
  • Update to version 0.0.20241108T172500 2024-11-08T17:25:00Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:

    • GO-2024-3260 CVE-2024-45794 GHSA-q78v-cv36-8fxj
    • GO-2024-3262 CVE-2024-10975 GHSA-2w5v-x29g-jw7j
  • Update to version 0.0.20241106T172143 2024-11-06T17:21:43Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:

    • GO-2024-3251 CVE-2024-10389 GHSA-q3rp-vvm7-j8jg
    • GO-2024-3252 CVE-2024-51746 GHSA-8pmp-678w-c8xx
    • GO-2024-3253 CVE-2024-48057 GHSA-ghx4-cgxw-7h9p
    • GO-2024-3254 CVE-2024-51735 GHSA-wvv7-wm5v-w2gv
Record
SUSE-SU-2024:4042-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/hashicorp/nomad
Go
through 1.9.1 None known
github.com/hashicorp/nomad
Go
before 1.9.2
1.9.2
govulncheck-vulndb
SUSE:Linux Enterprise Module for Package Hub 15 SP5
From an advisory covering 7 CVEs
before 0.0.20241112T145010-150000.1.17.1
0.0.20241112T145010-150000.1.17.1
govulncheck-vulndb
SUSE:Linux Enterprise Module for Package Hub 15 SP6
From an advisory covering 7 CVEs
before 0.0.20241112T145010-150000.1.17.1
0.0.20241112T145010-150000.1.17.1
govulncheck-vulndb
openSUSE:Leap 15.5
From an advisory covering 7 CVEs
before 0.0.20241112T145010-150000.1.17.1
0.0.20241112T145010-150000.1.17.1
govulncheck-vulndb
openSUSE:Leap 15.6
From an advisory covering 7 CVEs
before 0.0.20241112T145010-150000.1.17.1
0.0.20241112T145010-150000.1.17.1
nomad
Ubuntu:18.04:LTS
All versions, plus listed versions
0.4.0+dfsg-1
None known
nomad
Ubuntu:20.04:LTS
All versions, plus listed versions
0.8.7+dfsg1-1ubuntu1
None known
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 0.0.20241108T172500-1.1
0.0.20241108T172500-1.1

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-10975 is a high vulnerability (CVSS 7.7) in Hashicorp Nomad, published November 7, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in github.com/hashicorp/nomad 1.9.2.

References

Show 11 moreShow less
MoveEnter Open