Every CVE Search/ Get API key

CVE-2024-12692

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to...

8.8 HighFix available

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

7.14%Up 7.1 points since Dec 19, 2024
90%50%10%1%

What each source reports

NVD Score used 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-12692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
CVE List 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-12692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
EUVDEUVD-2024-51051 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
EUVD-2024-51051
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-2xhp-fvvw-3838 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to...

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
GHSA-2xhp-fvvw-3838
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
OSV 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2024-12692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2024-12692 8.8

Type Confusion in V8 in Google Chrome prior to 131.0.6778.204 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
DEBIAN-CVE-2024-12692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:0417-1 No score

Security update for chromium

This security update for Chromium to version 131.0.6778.204 (boo#1234704) fixes:

  • CVE-2024-12692: Type Confusion in V8
  • CVE-2024-12693: Out of bounds memory access in V8
  • CVE-2024-12694: Use after free in Compositing
  • CVE-2024-12695: Out of bounds write in V8
  • Various fixes from internal audits, fuzzing and other initiatives
Record
openSUSE-SU-2024:0417-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14607-1 No score

chromedriver-131.0.6778.204-1.1 on GA media

These are all security issues fixed in the chromedriver-131.0.6778.204-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14607-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
chromium
Debian:12
before 131.0.6778.204-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
131.0.6778.204-1~deb12u1
chromium
Debian:13
before 131.0.6778.204-1
131.0.6778.204-1
chromium
Debian:14
before 131.0.6778.204-1
131.0.6778.204-1
chromium
Debian:12
From an advisory covering 4 CVEs
before 131.0.6778.204-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
131.0.6778.204-1~deb12u1
chromium
SUSE:Package Hub 15 SP5
From an advisory covering 4 CVEs
before 131.0.6778.204-bp156.2.65.1
131.0.6778.204-bp156.2.65.1
chromium
SUSE:Package Hub 15 SP6
From an advisory covering 4 CVEs
before 131.0.6778.204-bp156.2.65.1
131.0.6778.204-bp156.2.65.1
chromium
openSUSE:Leap 15.5
From an advisory covering 4 CVEs
before 131.0.6778.204-bp156.2.65.1
131.0.6778.204-bp156.2.65.1
chromium
openSUSE:Leap 15.6
From an advisory covering 4 CVEs
before 131.0.6778.204-bp156.2.65.1
131.0.6778.204-bp156.2.65.1
chromium
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 131.0.6778.204-1.1
131.0.6778.204-1.1

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-12692 is a high vulnerability (CVSS 8.8) in Google Chrome, published December 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.14%, the 94th percentile. Fixed in chromium 131.0.6778.204-1~deb12u1.

References

Show 5 moreShow less
This page doesn't list everything

Left out here: 254 versions. The JSON record has them.

MoveEnter Open