Every CVE Search/ Get API key

CVE-2024-12911

SQL Injection in run-llama/llama_index

7.1 HighFix available

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
High

Exploit likelihood

0.52%Up 0.5 points since Mar 20, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.1

SQL Injection in run-llama/llama_index

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Record
CVE-2024-12911
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2025-6988 7.1

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Record
EUVD-2025-6988
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-jmgm-gx32-vp4w 7.1

LlamaIndex vulnerable to Creation of Temporary File in Directory with Insecure Permissions

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.12.3.

Record
GHSA-jmgm-gx32-vp4w
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Weakness
CWE-89, CWE-379
Updated
2026-11-02
NVD 7.1

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Record
CVE-2024-12911
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 7.1

SQL Injection in run-llama/llama_index

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Record
CVE-2024-12911
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-jmgm-gx32-vp4w 7.1

LlamaIndex vulnerable to Creation of Temporary File in Directory with Insecure Permissions

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.12.3.

Record
GHSA-jmgm-gx32-vp4w
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Weakness
CWE-379, CWE-89
Updated
2026-11-02
OSVPYSEC-2026-1555 7.1

LlamaIndex vulnerable to Creation of Temporary File in Directory with Insecure Permissions

A vulnerability in the default_jsonalyzer function of the JSONalyzeQueryEngine in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.12.3.

Record
PYSEC-2026-1555
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
llama-index
PyPI
before 0.12.3
0.12.3
llama-index
PyPI
before 0.12.3, plus listed versions
0.10.00.10.10.10.100.10.110.10.12
Show 45 moreShow less
0.10.130.10.13.post10.10.140.10.150.10.160.10.170.10.180.10.190.10.200.10.220.10.230.10.240.10.250.10.260.10.270.10.280.10.290.10.30.10.300.10.310.10.320.10.330.10.340.10.350.10.360.10.370.10.380.10.390.10.40.10.400.10.410.10.420.10.430.10.440.10.450.10.45.post10.10.460.10.470.10.480.10.48.post10.10.490.10.50.10.500.10.510.10.52
0.12.3

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-12911 is a high vulnerability (CVSS 7.1) in Llamaindex, published March 20, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in llama-index 0.12.3.

References

This page doesn't list everything

Left out here: 374 versions. The JSON record has them.

MoveEnter Open