Every CVE Search/ Get API key

CVE-2024-13918

Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page

8.0 HighFix available

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.60%Up 0.6 points since Mar 11, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.0

Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
CVE-2024-13918
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-54196 8.0

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
EUVD-2024-54196
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-546h-56qp-8jmw 4.7

Laravel framework susceptible to reflected cross-site scripting

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
GHSA-546h-56qp-8jmw
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 8.0

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
CVE-2024-13918
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 8.0

Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
CVE-2024-13918
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-546h-56qp-8jmw 4.7

Laravel framework susceptible to reflected cross-site scripting

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

Record
GHSA-546h-56qp-8jmw
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
laravel/framework
Packagist
11.9.0 up to 11.36.0
11.36.0
laravel/framework
Packagist
11.9.0 up to 11.36.0, plus listed versions
v11.10.0v11.11.0v11.11.1v11.12.0v11.13.0
Show 40 moreShow less
v11.14.0v11.15.0v11.16.0v11.17.0v11.18.0v11.18.1v11.19.0v11.20.0v11.21.0v11.22.0v11.23.0v11.23.1v11.23.2v11.23.3v11.23.4v11.23.5v11.24.0v11.24.1v11.25.0v11.26.0v11.27.0v11.27.1v11.27.2v11.28.0v11.28.1v11.29.0v11.30.0v11.31.0v11.32.0v11.33.0v11.33.1v11.33.2v11.34.0v11.34.1v11.34.2v11.35.0v11.35.1v11.9.0v11.9.1v11.9.2
11.36.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-13918 is a high vulnerability (CVSS 8.0) in Laravel Framework, published March 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.60%, the 48th percentile. Fixed in laravel/framework 11.36.0.

References

Show 4 moreShow less
MoveEnter Open