CVE-2024-21511
MySQL2 for Node Arbitrary Code Injection
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
CVE-2024-21511- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2024-1092
9.8
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
EUVD-2024-1092- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4rch-2fh8-94vw
9.8
MySQL2 for Node Arbitrary Code Injection
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
GHSA-4rch-2fh8-94vw- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
9.8
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
CVE-2024-21511- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
9.8
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
CVE-2024-21511- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-4rch-2fh8-94vw
9.8
MySQL2 for Node Arbitrary Code Injection
Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.
- Record
GHSA-4rch-2fh8-94vw- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVCLSA-2026-1773274566 No score
TuxCare security update for mysql2 (3 CVEs)
TuxCare rebuilt mysql2 to address 3 CVEs. Fixed in 2.3.3-tuxcare.2.
- Record
CLSA-2026-1773274566- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2024-21511 No score
CVE-2024-21511 in mysql2 - Patched by Root
Root has patched CVE-2024-21511 in the mysql2 package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2024-21511- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mysql2npm |
before 3.9.7 | 3.9.7 |
mysql2TuxCare:npm From an advisory covering 3 CVEs |
2.3.3-tuxcare.0 up to 2.3.3-tuxcare.2, plus listed versions 2.3.32.3.3-tuxcare.1 |
2.3.3-tuxcare.2 |
mysql2Root:npm |
before 2.3.3-aikido.3 | 2.3.3-aikido.33.7.1-aikido.43.9.2-aikido.13.9.2-aikido.22.3.3-aikido.43.7.1-aikido.33.9.7-aikido.2 |
@rootio/mysql2Root:npm |
before 2.3.3-root.io.2 | 2.3.3-root.io.22.3.3-root.io.12.3.3-root.io.33.7.1-root.io.43.9.2-root.io.13.9.2-root.io.22.3.3-root.io.43.7.1-root.io.33.9.7-root.io.13.9.7-root.io.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-21511 is a critical vulnerability (CVSS 9.8) in Mysql2, published April 23, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 64th percentile. Fixed in mysql2 3.9.7.
References
security.snyk.io/vuln/SNYK-JS-MYSQL2-6670046
github.com/sidorares/node-mysql2/releases/tag/v3.9.7
github.com/sidorares/node-mysql2/pull/2608
github.com/sidorares/node-mysql2/commit/7d4b098c7e29d5a6cb9eac2633bfcc2f0f1db713
nvd.nist.gov/vuln/detail/CVE-2024-21511
github.com/advisories/GHSA-4rch-2fh8-94vw
github.com/CVEProject/cvelistV5/tree/main/cves/2024/21xxx/CVE-2024-21511.json
github.com/sidorares/node-mysql2