CVE-2024-21536
Denial of service in http-proxy-middleware
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.7
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
CVE-2024-21536- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2024-3014
8.7
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
EUVD-2024-3014- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c7qv-q95q-8v27
7.5
Denial of service in http-proxy-middleware
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
GHSA-c7qv-q95q-8v27- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.7
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
CVE-2024-21536- CVSS 4.0
- 7.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
7.7
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
CVE-2024-21536- CVSS 4.0
- 7.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVGHSA-c7qv-q95q-8v27
7.5
Denial of service in http-proxy-middleware
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
- Record
GHSA-c7qv-q95q-8v27- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
Show 6 moreShow less
OSVCLSA-2026-1774657386 No score
TuxCare security update for http-proxy-middleware (1 CVE)
TuxCare rebuilt http-proxy-middleware to address 1 CVE. Fixed in 0.19.1-tuxcare.1.
- Record
CLSA-2026-1774657386- Updated
- 2026-11-02
OSVCLSA-2026-1776299658 No score
TuxCare security update for http-proxy-middleware (1 CVE)
TuxCare rebuilt http-proxy-middleware to address 1 CVE. Fixed in 0.18.0-tuxcare.1.
- Record
CLSA-2026-1776299658- Updated
- 2026-11-02
OSVCLSA-2026-1784164086 No score
TuxCare security update for http-proxy-middleware (1 CVE)
TuxCare rebuilt http-proxy-middleware to address 1 CVE. Fixed in 0.17.3-tuxcare.1.
- Record
CLSA-2026-1784164086- Updated
- 2026-11-02
OSVCLSA-2026-1784164093 No score
TuxCare security update for http-proxy-middleware (1 CVE)
TuxCare rebuilt http-proxy-middleware to address 1 CVE. Fixed in 0.17.2-tuxcare.1.
- Record
CLSA-2026-1784164093- Updated
- 2026-11-02
OSVCLSA-2026-1784596275 No score
TuxCare security update for http-proxy-middleware (1 CVE)
TuxCare rebuilt http-proxy-middleware to address 1 CVE. Fixed in 1.3.1-tuxcare.1.
- Record
CLSA-2026-1784596275- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2024-21536 No score
CVE-2024-21536 in http-proxy-middleware - Patched by Root
Root has patched CVE-2024-21536 in the http-proxy-middleware package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2024-21536- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
http-proxy-middlewarenpm |
before 2.0.7 | 2.0.7 |
http-proxy-middlewarenpm |
3.0.0 up to 3.0.3 | 3.0.3 |
http-proxy-middlewareTuxCare:npm |
0.19.1-tuxcare.0 up to 0.19.1-tuxcare.1, plus listed versions 0.19.1 |
0.19.1-tuxcare.1 |
http-proxy-middlewareTuxCare:npm |
0.18.0-tuxcare.0 up to 0.18.0-tuxcare.1, plus listed versions 0.18.0 |
0.18.0-tuxcare.1 |
http-proxy-middlewareTuxCare:npm |
0.17.3-tuxcare.0 up to 0.17.3-tuxcare.1, plus listed versions 0.17.3 |
0.17.3-tuxcare.1 |
http-proxy-middlewareTuxCare:npm |
0.17.2-tuxcare.0 up to 0.17.2-tuxcare.1, plus listed versions 0.17.2 |
0.17.2-tuxcare.1 |
http-proxy-middlewareTuxCare:npm |
1.3.1-tuxcare.0 up to 1.3.1-tuxcare.1, plus listed versions 1.3.1 |
1.3.1-tuxcare.1 |
http-proxy-middlewareRoot:npm |
before 0.19.1-aikido.2 | 0.19.1-aikido.21.3.1-aikido.10.19.1-aikido.32.0.3-aikido.12.0.7-aikido.1 |
@rootio/http-proxy-middlewareRoot:npm |
before 0.19.1-root.io.1 | 0.19.1-root.io.10.19.1-root.io.21.3.1-root.io.10.19.1-root.io.32.0.3-root.io.12.0.7-root.io.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-21536 is a high vulnerability (CVSS 8.7) in Chimurai Http-proxy-middleware, published October 19, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 64th percentile. Fixed in http-proxy-middleware 2.0.7.
References
security.snyk.io/vuln/SNYK-JS-HTTPPROXYMIDDLEWARE-8229906
security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-8309098
gist.github.com/mhassan1/28be67266d82a53708ed59ce5dc3c94a
github.com/chimurai/http-proxy-middleware/commit/788b21e4aff38332d6319557d4a5b1b13b1f9a22
github.com/chimurai/http-proxy-middleware/commit/0b4274e8cc9e9a2c5a06f35fbf456ccfcebc55a5
nvd.nist.gov/vuln/detail/CVE-2024-21536
github.com/advisories/GHSA-c7qv-q95q-8v27
github.com/CVEProject/cvelistV5/tree/main/cves/2024/21xxx/CVE-2024-21536.json
github.com/chimurai/http-proxy-middleware