Every CVE Search/ Get API key

CVE-2024-21544

Browsershot Local File Inclusion

7.7 HighFix available

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
None

Exploit likelihood

0.57%Up 0.5 points since Dec 13, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.7

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
CVE-2024-21544
CVSS 4.0
7.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N/E:P
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2024-3469 7.7

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
EUVD-2024-3469
CVSS 4.0
7.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P
Updated
2026-11-02
GitHub AdvisoriesGHSA-g2r4-phv7-5fgv 6.6

Browsershot Local File Inclusion

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
GHSA-g2r4-phv7-5fgv
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
NVD 6.6

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
CVE-2024-21544
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
OSV 6.6

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
CVE-2024-21544
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-g2r4-phv7-5fgv 6.6

Browsershot Local File Inclusion

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Record
GHSA-g2r4-phv7-5fgv
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVCLSA-2026-1768956702 No score

TuxCare security update for spatie/browsershot (5 CVEs)

TuxCare rebuilt spatie/browsershot to address 5 CVEs. Fixed in 3.61.0-p1+tuxcare.

Record
CLSA-2026-1768956702
Updated
2026-11-02
OSVCLSA-2026-1777509609 No score

TuxCare security update for spatie/browsershot (5 CVEs)

TuxCare rebuilt spatie/browsershot to address 5 CVEs. Fixed in 4.4.0-p2+tuxcare.

Record
CLSA-2026-1777509609
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
spatie/browsershot
Packagist
before 5.0.1
5.0.1
spatie/browsershot
TuxCare:Packagist
From an advisory covering 5 CVEs
3.61.0 up to 3.61.0-p1+tuxcare
3.61.0-p1+tuxcare
spatie/browsershot
TuxCare:Packagist
From an advisory covering 5 CVEs
4.4.0 up to 4.4.0-p2+tuxcare, plus listed versions
4.4.0-p1+tuxcare
4.4.0-p2+tuxcare
spatie/browsershot
Packagist
before 5.0.1, plus listed versions
0.1.00.1.10.1.20.1.31.0.0
Show 45 moreShow less
1.1.01.2.01.2.11.2.21.2.31.2.41.3.01.4.01.5.01.5.11.5.21.5.31.5.41.6.01.7.01.8.01.9.01.9.12.0.02.0.12.0.22.0.32.1.02.2.02.3.02.4.02.4.12.4.23.0.03.1.03.10.03.11.03.11.13.12.03.13.03.14.03.14.13.15.03.16.03.16.13.17.03.18.03.19.03.2.03.2.1
5.0.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-21544 is a high vulnerability (CVSS 7.7) in spatie/browsershot, published December 13, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in spatie/browsershot 5.0.1.

References

This page doesn't list everything

Left out here: 103 versions. The JSON record has them.

MoveEnter Open