CVE-2024-21808
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an...
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- Active
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
CVE-2024-21808- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 4.2 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-92
- Updated
- 2026-11-02
EUVDEUVD-2024-19420
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
EUVD-2024-19420- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h3rc-229h-wgjg
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an...
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
GHSA-h3rc-229h-wgjg- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 4.2 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
NVD
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
CVE-2024-21808- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 4.2 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-92
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-21808
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
DEBIAN-CVE-2024-21808- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-21808
1.0
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
UBUNTU-CVE-2024-21808- CVSS 4.0
- 1.0 Low
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 4.2 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSV No score
Improper buffer restrictions in some Intel(R) VPL software before version 24.1.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
- Record
CVE-2024-21808- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
intel-mediasdkDebian:12 |
All versions, plus listed versions 22.5.4-1 |
None known |
onevpl-intel-gpuDebian:12 |
All versions, plus listed versions 22.6.4-123.2.3-124.3.3-124.3.4-125.1.2-1 Show 5 moreShow less25.1.4-125.3.1-126.1.2-126.1.2-1.126.3.3-1 |
None known |
onevpl-intel-gpuDebian:13 |
before 24.3.3-1 | 24.3.3-1 |
onevpl-intel-gpuDebian:14 |
before 24.3.3-1 | 24.3.3-1 |
intel-mediasdkUbuntu:20.04:LTS |
All versions, plus listed versions 19.2.1-119.4.0-119.4.0-1build120.1.0-0ubuntu1 |
None known |
intel-mediasdkUbuntu:22.04:LTS |
All versions, plus listed versions 21.1.0-121.3.4-122.1.0-122.3.0-1 |
None known |
onevpl-intel-gpuUbuntu:22.04:LTS |
All versions, plus listed versions 22.2.0-122.3.2-1 |
None known |
intel-mediasdkUbuntu:24.04:LTS |
All versions, plus listed versions 22.5.4-1 |
None known |
onevpl-intel-gpuUbuntu:24.04:LTS |
All versions, plus listed versions 23.2.3-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-21808 is a low vulnerability (CVSS 1.0) in intel-mediasdk, published November 13, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.19%, the 8th percentile. Fixed in onevpl-intel-gpu 24.3.3-1.