CVE-2024-22116
Remote code execution within ping script
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.9
Remote code execution within ping script
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
CVE-2024-22116- CVSS 3.1
- 9.9 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2024-19712
9.9
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
EUVD-2024-19712- CVSS 3.1
- 9.9 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-3wch-5xm2-547f
9.9
An administrator with restricted permissions can exploit the script execution functionality...
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
GHSA-3wch-5xm2-547f- CVSS 3.1
- 9.9 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
9.9
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
CVE-2024-22116- CVSS 3.1
- 9.9 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
7.2
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
CVE-2024-22116- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-22116
7.2
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
DEBIAN-CVE-2024-22116- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-22116
9.9
An administrator with restricted permissions can exploit the script execution functionality within the Monitoring Hosts section. The lack of default escaping for script parameters enabled this user ability to execute arbitrary code via the Ping script, thereby compromising infrastructure.
- Record
UBUNTU-CVE-2024-22116- CVSS 3.1
- 9.9 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-05
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zabbixDebian:12 |
All versions, plus listed versions 1:6.0.14+dfsg-11:6.0.23+dfsg-11:6.0.23+dfsg-1~bpo12+11:6.0.24+dfsg-11:6.0.25+dfsg-1 Show 24 moreShow less1:6.0.29+dfsg-11:7.0.0+dfsg-11:7.0.0+dfsg-21:7.0.0+dfsg-2~bpo12+11:7.0.1+dfsg-11:7.0.1+dfsg-1~bpo12+11:7.0.10+dfsg-11:7.0.10+dfsg-21:7.0.2+dfsg-11:7.0.2+dfsg-1~bpo12+11:7.0.22+dfsg-11:7.0.22+dfsg-1.11:7.0.22+dfsg-1~bpo13+11:7.0.22+dfsg-1~deb13u11:7.0.27+dfsg-11:7.0.29+dfsg-11:7.0.29+dfsg-21:7.0.29+dfsg-2~bpo13+11:7.0.3+dfsg-11:7.0.5+dfsg-11:7.0.5+dfsg-1~bpo12+11:7.0.6+dfsg-11:7.0.9+dfsg-11:7.0.9+dfsg-1~bpo12+1 |
None known |
zabbixDebian:13 |
before 1:7.0.0+dfsg-1 | 1:7.0.0+dfsg-1 |
zabbixDebian:14 |
before 1:7.0.0+dfsg-1 | 1:7.0.0+dfsg-1 |
zabbixDebian:11 From an advisory covering 31 CVEs |
before 1:5.0.44+dfsg-1+deb11u1, plus listed versions 1:5.0.14+dfsg-11:5.0.14+dfsg-1~bpo11+11:5.0.17+dfsg-11:5.0.17+dfsg-1~bpo11+11:5.0.8+dfsg-1 |
1:5.0.44+dfsg-1+deb11u1 |
zabbixUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu1 Show 4 moreShow less1:2.2.2+dfsg-1ubuntu1+esm11:2.2.2+dfsg-1ubuntu1+esm31:2.2.2+dfsg-1ubuntu1+esm41:2.2.2+dfsg-1ubuntu1+esm5 |
None known |
zabbixUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.1 Show 4 moreShow less1:2.4.7+dfsg-2ubuntu2.1+esm11:2.4.7+dfsg-2ubuntu2.1+esm21:2.4.7+dfsg-2ubuntu2.1+esm31:2.4.7+dfsg-2ubuntu2.1+esm4 |
None known |
zabbixUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm11:3.0.12+dfsg-1ubuntu0.1~esm21:3.0.12+dfsg-1ubuntu0.1~esm31:3.0.12+dfsg-1ubuntu0.1~esm4 |
None known |
zabbixUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-1 Show 5 moreShow less1:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-11:4.0.17+dfsg-1ubuntu0.1~esm11:4.0.17+dfsg-1ubuntu0.1~esm2 |
None known |
zabbixUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1:5.0.8+dfsg-1build11:5.0.14+dfsg-11:5.0.17+dfsg-11:5.0.17+dfsg-1ubuntu0.1~esm1 |
None known |
zabbixUbuntu:25.10 |
All versions, plus listed versions 1:7.0.10+dfsg-21:7.0.10+dfsg-2build1 |
None known |
zabbixUbuntu:26.10 |
All versions, plus listed versions 1:7.0.22+dfsg-11:7.0.22+dfsg-1.11:7.0.22+dfsg-1.1build11:7.0.22+dfsg-1.1build21:7.0.27+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| affected, facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-22116 is a critical vulnerability (CVSS 9.9) in Zabbix, published August 9, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in zabbix 1:7.0.0+dfsg-1.