Every CVE Search/ Get API key

CVE-2024-22258

CVE-2024-22258: PKCE Downgrade in Spring Authorization Server

6.1 MediumFix available

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.53%Up 0.5 points since Mar 20, 2024
90%50%10%1%

What each source reports

CVE List Score used 6.1

CVE-2024-22258: PKCE Downgrade in Spring Authorization Server

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
CVE-2024-22258
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-470
Updated
2026-11-02
EUVDEUVD-2024-1035 6.1

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
EUVD-2024-1035
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-x637-x8p3-5p22 6.1

Improper Authentication in Spring Authorization Server

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
GHSA-x637-x8p3-5p22
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-287, CWE-470
Updated
2026-11-02
NVD 6.1

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
CVE-2024-22258
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-470
Updated
2026-11-02
OSVGHSA-x637-x8p3-5p22 6.1

Improper Authentication in Spring Authorization Server

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.

Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.

An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
GHSA-x637-x8p3-5p22
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-287, CWE-470
Updated
2026-11-02
OSVUBUNTU-CVE-2024-22258 6.1

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Record
UBUNTU-CVE-2024-22258
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1768522124 No score

TuxCare security update for org.springframework.security:spring-security-oauth2-authorization-server (1 CVE)

TuxCare rebuilt org.springframework.security:spring-security-oauth2-authorization-server to address 1 CVE. Fixed in 1.1.4-tuxcare.1.

Record
CLSA-2026-1768522124
Updated
2026-11-02
OSVROOT-APP-MAVEN-CVE-2024-22258 No score

CVE-2024-22258 in io.root.org.springframework.security:spring-security-oauth2-authorization-server - Patched by Root

Root has patched CVE-2024-22258 in the io.root.org.springframework.security:spring-security-oauth2-authorization-server package for Root:Maven. Multiple fixed versions available.

Record
ROOT-APP-MAVEN-CVE-2024-22258
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.springframework.security:spring-security-oauth2-authorization-server
Maven
before 1.1.6
1.1.6
org.springframework.security:spring-security-oauth2-authorization-server
Maven
1.2.0 up to 1.2.3
1.2.3
org.springframework.security:spring-security-oauth2-authorization-server
TuxCare:Maven
1.1.4 up to 1.1.4-tuxcare.1
1.1.4-tuxcare.1
org.springframework.security:spring-security-oauth2-authorization-server
Maven
before 1.1.6, plus listed versions
0.2.00.2.10.2.20.2.30.3.0
Show 18 moreShow less
0.3.10.4.00.4.10.4.20.4.30.4.40.4.51.0.01.0.11.0.21.0.31.0.41.1.01.1.11.1.21.1.31.1.41.1.5
1.1.6
org.springframework.security:spring-security-oauth2-authorization-server
Maven
1.2.0 up to 1.2.3, plus listed versions
1.2.11.2.2
1.2.3
io.root.org.springframework.security:spring-security-oauth2-authorization-server
Root:Maven
before 1.2.0-root.io.1
1.2.0-root.io.11.2.0-root.io.2
org.springframework.security:spring-security-oauth2-authorization-server
Root:Maven
before 1.2.0-aikido.1
1.2.0-aikido.11.2.0-aikido.2
spring
Ubuntu:16.04:LTS
All versions, plus listed versions
100.0+dfsg-2100.0+dfsg-2build1
None known
spring
Ubuntu:18.04:LTS
All versions, plus listed versions
103.0+dfsg2-1103.0+dfsg2-1build1104.0+dfsg-2
None known
spring
Ubuntu:20.04:LTS
All versions, plus listed versions
104.0+dfsg-3build2104.0+dfsg-4ubuntu1104.0+dfsg-4ubuntu2104.0+dfsg-4ubuntu5104.0+dfsg-4ubuntu6104.0+dfsg-4ubuntu7
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
spring
Ubuntu:22.04:LTS
All versions, plus listed versions
105.0.1+dfsg-2105.0.1+dfsg-3ubuntu1105.0.1+dfsg-3ubuntu2105.0.1+dfsg-4
None known
spring
Ubuntu:24.04:LTS
All versions, plus listed versions
106.0+dfsg-2106.0+dfsg-3106.0+dfsg-3build2106.0+dfsg-3build3
None known
spring
Ubuntu:25.10
All versions, plus listed versions
106.0+dfsg-4
None known
spring
Ubuntu:26.10
All versions, plus listed versions
106.0+dfsg-4106.0+dfsg-5
None known
spring
Ubuntu:26.04:LTS
All versions, plus listed versions
106.0+dfsg-4
None known

History

History
RecordedChangedSources
aliases, products, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-22258 is a medium vulnerability (CVSS 6.1) in Spring, published March 20, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 44th percentile. Fixed in org.springframework.security:spring-security-oauth2-authorization-server 1.1.6.

References

MoveEnter Open