Every CVE Search/ Get API key

CVE-2024-22369

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

7.8 HighPublic exploitFix available

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.75%Up 0.7 points since Feb 21, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.8

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
CVE-2024-22369
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502, CWE-502
Updated
2026-11-02
EUVDEUVD-2024-0478 7.8

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
EUVD-2024-0478
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-36xr-4x2f-cfj9 8.6

Deserialization of Untrusted Data in Apache Camel SQL

Deserialization of Untrusted Data vulnerability in Apache Camel SQL Component. This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
GHSA-36xr-4x2f-cfj9
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
NVD 7.8

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
CVE-2024-22369
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 7.8

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
CVE-2024-22369
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVGHSA-36xr-4x2f-cfj9 8.6

Deserialization of Untrusted Data in Apache Camel SQL

Deserialization of Untrusted Data vulnerability in Apache Camel SQL Component. This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Record
GHSA-36xr-4x2f-cfj9
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-sql
Maven
3.0.0 up to 3.21.4
3.21.4
org.apache.camel:camel-sql
Maven
3.22.0 up to 3.22.1
3.22.1
org.apache.camel:camel-sql
Maven
4.0.0 up to 4.0.4
4.0.4
org.apache.camel:camel-sql
Maven
4.1.0 up to 4.4.0
4.4.0
org.apache.camel:camel-sql
Maven
3.0.0 up to 3.21.4, plus listed versions
3.0.13.1.03.10.03.11.03.11.1
Show 45 moreShow less
3.11.23.11.33.11.43.11.53.11.63.11.73.12.03.13.03.14.03.14.13.14.103.14.23.14.33.14.43.14.53.14.63.14.73.14.83.14.93.15.03.16.03.17.03.18.03.18.13.18.23.18.33.18.43.18.53.18.63.18.73.18.83.19.03.2.03.20.03.20.13.20.23.20.33.20.43.20.53.20.63.20.73.20.83.20.93.21.03.21.1
3.21.4
org.apache.camel:camel-sql
Maven
4.0.0 up to 4.0.4, plus listed versions
4.0.14.0.24.0.3
4.0.4
org.apache.camel:camel-sql
Maven
4.1.0 up to 4.4.0, plus listed versions
4.2.04.3.0
4.4.0

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHuboscerd/CVE-2024-223692024-01-10

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-22369 is a high vulnerability (CVSS 7.8) in Apache Camel, published February 20, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.75%, the 55th percentile. Fixed in org.apache.camel:camel-sql 3.21.4.

References

Show 11 moreShow less
This page doesn't list everything

Left out here: 22 versions. The JSON record has them.

MoveEnter Open