CVE-2024-22513
Improper Privilege Management in djangorestframework-simplejwt
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.5
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
CVE-2024-22513- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-306
- Updated
- 2026-11-02
EUVDEUVD-2024-0836
5.5
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
EUVD-2024-0836- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5vcc-86wm-547q No score
Improper Privilege Management in djangorestframework-simplejwt
djangorestframework-simplejwt before version 5.5.1 is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
GHSA-5vcc-86wm-547q- Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
5.5
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
CVE-2024-22513- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-306
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-22513
5.5
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
DEBIAN-CVE-2024-22513- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-22513
5.5
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
UBUNTU-CVE-2024-22513- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSV No score
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
CVE-2024-22513- Updated
- 2026-11-02
OSVGHSA-5vcc-86wm-547q No score
Improper Privilege Management in djangorestframework-simplejwt
djangorestframework-simplejwt before version 5.5.1 is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
GHSA-5vcc-86wm-547q- Weakness
- CWE-269
- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15699-1 No score
python311-djangorestframework-simplejwt-5.5.1-1.1 on GA media
These are all security issues fixed in the python311-djangorestframework-simplejwt-5.5.1-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15699-1- Updated
- 2026-11-02
OSVPYSEC-2026-1305 No score
Improper Privilege Management in djangorestframework-simplejwt
djangorestframework-simplejwt before version 5.5.1 is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
- Record
PYSEC-2026-1305- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
djangorestframework-simplejwtPyPI |
before 5.5.1 | 5.5.1 |
python-djangorestframework-simplejwtDebian:12 |
All versions, plus listed versions 5.2.2-15.3.0-15.3.1-15.3.1-25.4.0-1 Show 4 moreShow less5.5.0-15.5.1-15.5.1-25.5.1-3 |
None known |
python-djangorestframework-simplejwtDebian:13 |
All versions, plus listed versions 5.5.0-15.5.1-15.5.1-25.5.1-3 |
None known |
python-djangorestframework-simplejwtDebian:14 |
All versions, plus listed versions 5.5.0-15.5.1-15.5.1-25.5.1-3 |
None known |
djangorestframework-simplejwtPyPI |
before 5.5.1, plus listed versions 1.01.11.21.2.11.3 Show 42 moreShow less1.41.51.5.12.0.02.0.12.0.22.0.32.0.42.0.52.13.03.13.23.2.13.2.23.2.33.34.0.04.1.04.1.14.1.24.1.34.1.44.1.54.2.04.3.04.4.04.5.04.6.04.7.04.7.14.7.24.8.05.0.05.1.05.2.05.2.15.2.25.3.05.3.15.4.05.5.0 |
5.5.1 |
python-djangorestframework-simplejwtUbuntu:22.04:LTS |
All versions, plus listed versions 5.0.0-1 |
None known |
python-djangorestframework-simplejwtUbuntu:24.04:LTS |
All versions, plus listed versions 5.2.2-15.3.0-15.3.1-1 |
None known |
python-djangorestframework-simplejwtUbuntu:25.10 |
All versions, plus listed versions 5.4.0-15.5.0-1 |
None known |
python-djangorestframework-simplejwtUbuntu:26.10 |
All versions, plus listed versions 5.5.1-15.5.1-2 |
None known |
python-djangorestframework-simplejwtUbuntu:26.04:LTS |
All versions, plus listed versions 5.5.0-15.5.1-1 |
None known |
python-djangorestframework-simplejwtopenSUSE:Tumbleweed |
before 5.5.1-1.1 | 5.5.1-1.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | djangorestframework-simplejwt 5.3.1 - Information Disclosure | 2024-04-15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-22513 is a medium vulnerability (CVSS 5.5) in djangorestframework-simplejwt, published March 16, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.80%, the 56th percentile. Fixed in djangorestframework-simplejwt 5.5.1.
References
github.com/dmdhrumilmistry/CVEs/tree/main/CVE-2024-22513
nvd.nist.gov/vuln/detail/CVE-2024-22513
github.com/jazzband/djangorestframework-simplejwt/blob/c791e987332ed5e22a86428160d6372b1d85ffae/rest_framework_simplejwt/tokens.py
github.com/jazzband/djangorestframework-simplejwt/issues/779
github.com/jazzband/djangorestframework-simplejwt/pull/872
github.com/jazzband/djangorestframework-simplejwt/pull/873
Show 11 moreShow less
github.com/jazzband/djangorestframework-simplejwt/pull/891
github.com/jazzband/djangorestframework-simplejwt/commit/14e8b2cf5fa0df954af82ff3926fa6d6c4ecf13e
github.com/jazzband/djangorestframework-simplejwt/commit/1ad763bfe73936515aa4756263338c63866364c9
github.com/jazzband/djangorestframework-simplejwt/commit/a2d0a0201b6123536ecf76cd4d0ec7389317d0a7
github.com/advisories/GHSA-5vcc-86wm-547q
security-tracker.debian.org/tracker/CVE-2024-22513
github.com/jazzband/djangorestframework-simplejwt
pypi.org/project/djangorestframework-simplejwt
ubuntu.com/security/CVE-2024-22513
cve.org/CVERecord?id=CVE-2024-22513
suse.com/security/cve/CVE-2024-22513