CVE-2024-23525
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to...
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
CVE-2024-23525- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
CVE-2024-23525- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
EUVDEUVD-2024-21020
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
EUVD-2024-21020- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-cxjh-j6f8-vrmf
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to...
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
GHSA-cxjh-j6f8-vrmf- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
CVE-2024-23525- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-23525
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
DEBIAN-CVE-2024-23525- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-23525
6.5
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Record
UBUNTU-CVE-2024-23525- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13760-1 No score
perl-Spreadsheet-ParseXLSX-0.310.0-1.1 on GA media
These are all security issues fixed in the perl-Spreadsheet-ParseXLSX-0.310.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13760-1- Updated
- 2026-11-02
OSVUSN-6769-1 No score
libspreadsheet-parsexlsx-perl vulnerabilities
Le Dinh Hai discovered that Spreadsheet::ParseXLSX did not properly manage memory during cell merge operations. An attacker could possibly use this issue to consume large amounts of memory, resulting in a denial of service condition. (CVE-2024-22368)
An Pham discovered that Spreadsheet::ParseXLSX allowed the processing of external entities in a default configuration. An attacker could possibly use this vulnerability to execute an XML External Entity (XXE) injection attack. (CVE-2024-23525)
- Record
USN-6769-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libspreadsheet-parsexlsx-perlDebian:12 |
before 0.27-3+deb12u2, plus listed versions 0.27-30.27-3+deb12u1 |
0.27-3+deb12u2 |
libspreadsheet-parsexlsx-perlDebian:13 |
before 0.31-1 | 0.31-1 |
libspreadsheet-parsexlsx-perlDebian:14 |
before 0.31-1 | 0.31-1 |
libspreadsheet-parsexlsx-perlDebian:10 From an advisory covering 2 CVEs |
before 0.27-2+deb10u1, plus listed versions 0.27-2 |
0.27-2+deb10u1 |
libspreadsheet-parsexlsx-perlUbuntu:20.04:LTS |
before 0.27-2+deb10u1build0.20.04.1, plus listed versions 0.27-2 |
0.27-2+deb10u1build0.20.04.1 |
libspreadsheet-parsexlsx-perlUbuntu:22.04:LTS |
before 0.27-2.1+deb11u2build0.22.04.1, plus listed versions 0.27-2.1 |
0.27-2.1+deb11u2build0.22.04.1 |
libspreadsheet-parsexlsx-perlUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 0.27-2+deb10u1build0.20.04.1, plus listed versions 0.27-2 |
0.27-2+deb10u1build0.20.04.1 |
libspreadsheet-parsexlsx-perlUbuntu:22.04:LTS From an advisory covering 2 CVEs |
before 0.27-2.1+deb11u2build0.22.04.1, plus listed versions 0.27-2.1 |
0.27-2.1+deb11u2build0.22.04.1 |
perl-Spreadsheet-ParseXLSXopenSUSE:Tumbleweed |
before 0.310.0-1.1 | 0.310.0-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-23525 is a medium vulnerability (CVSS 6.5) in Tozt Spreadsheet\, published January 17, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in libspreadsheet-parsexlsx-perl 0.27-3+deb12u2.
References
metacpan.org/release/NUDDLEGG/Spreadsheet-ParseXLSX-0.30/changes
gist.github.com/phvietan/d1c95a88ab6e17047b0248d6bf9eac4a
github.com/MichaelDaum/spreadsheet-parsexlsx/issues/10
openwall.com/lists/oss-security/2024/01/18/4
lists.debian.org/debian-lts-announce/2024/01/msg00018.html
security.metacpan.org/2024/02/10/vulnerable-spreadsheet-parsing-modules.html
Show 10 moreShow less
nvd.nist.gov/vuln/detail/CVE-2024-23525
github.com/advisories/GHSA-cxjh-j6f8-vrmf
github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23525.json
security-tracker.debian.org/tracker/CVE-2024-23525
ubuntu.com/security/CVE-2024-23525
github.com/MichaelDaum/spreadsheet-parsexlsx/commit/1d55f90caf433c7442e5be21a1849af2b5522ffe
cve.org/CVERecord?id=CVE-2024-23525
ubuntu.com/security/notices/USN-6769-1
ubuntu.com/security/CVE-2024-22368
suse.com/security/cve/CVE-2024-23525