CVE-2024-2430
Website Content in Page or Post < 2024.04.09 - Contributor+ Stored Cross-Site Scripting
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
- Record
CVE-2024-2430- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List
6.5
Website Content in Page or Post < 2024.04.09 - Contributor+ Stored Cross-Site Scripting
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
- Record
CVE-2024-2430- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
EUVDEUVD-2024-27381
6.5
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
- Record
EUVD-2024-27381- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6vqv-rxj8-5fq9
5.4
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and...
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
- Record
GHSA-6vqv-rxj8-5fq9- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13938-1 No score
python310-sqlparse-0.5.0-1.1 on GA media
These are all security issues fixed in the python310-sqlparse-0.5.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13938-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11221-1 No score
python313-sqlparse-0.5.5-2.1 on GA media
These are all security issues fixed in the python313-sqlparse-0.5.5-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11221-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-sqlparseopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 0.5.0-1.1 | 0.5.0-1.1 |
python-sqlparseopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 0.5.5-2.1 | 0.5.5-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-2430 is a medium vulnerability (CVSS 5.4) in Matteoenna Website Content In Page Or Post, published June 15, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.31%, the 24th percentile. No source names a fixed version.