CVE-2024-24778
Apache StreamPipes: Resources Permission Escalation
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Apache StreamPipes: Resources Permission Escalation
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
CVE-2024-24778- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
EUVDEUVD-2024-22157
6.5
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
EUVD-2024-22157- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vm7w-2724-5m23
6.5
Apache StreamPipes has improper privilege management in a REST interface
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was known.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
GHSA-vm7w-2724-5m23- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
6.5
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
CVE-2024-24778- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
OSV
6.5
Apache StreamPipes: Resources Permission Escalation
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
CVE-2024-24778- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVGHSA-vm7w-2724-5m23
6.5
Apache StreamPipes has improper privilege management in a REST interface
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was known.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
GHSA-vm7w-2724-5m23- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVPYSEC-2025-66 No score
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.
This issue affects Apache StreamPipes: through 0.95.1.
Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Record
PYSEC-2025-66- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.streampipes:streampipes-parentMaven |
before 0.97.0 | 0.97.0 |
streampipesPyPI |
before 0.97.0 | 0.97.0 |
org.apache.streampipes:streampipes-parentMaven |
before 0.97.0, plus listed versions 0.66.00.67.00.68.00.69.00.70.0 Show 6 moreShow less0.90.00.91.00.92.00.93.00.95.00.95.1 |
0.97.0 |
streampipesPyPI |
before 0.97.0, plus listed versions 0.0.2.dev00.91.00.92.00.93.00.95.0 |
0.97.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-24778 is a medium vulnerability (CVSS 6.5) in Apache Streampipes, published March 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in org.apache.streampipes:streampipes-parent 0.97.0.
References
lists.apache.org/thread/j14w6wghlwwrgfgc6hoz9f94fwxtlgzh
openwall.com/lists/oss-security/2025/03/03/1
nvd.nist.gov/vuln/detail/CVE-2024-24778
github.com/pypa/advisory-database/tree/main/vulns/streampipes/PYSEC-2025-66.yaml
github.com/advisories/GHSA-vm7w-2724-5m23
github.com/CVEProject/cvelistV5/tree/main/cves/2024/24xxx/CVE-2024-24778.json
github.com/apache/streampipes