CVE-2024-25189
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it...
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
CVE-2024-25189- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-203
- Updated
- 2026-11-02
CVE List
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
CVE-2024-25189- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-203
- Updated
- 2026-11-02
EUVDEUVD-2024-22525
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
EUVD-2024-22525- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m5gq-732f-j9v6
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it...
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
GHSA-m5gq-732f-j9v6- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-203
- Updated
- 2026-11-02
OSV
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
CVE-2024-25189- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-25189
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
DEBIAN-CVE-2024-25189- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-25189
9.8
libjwt 1.15.3 uses strcmp (which is not constant time) to verify authentication, which makes it easier to bypass authentication via a timing side channel.
- Record
UBUNTU-CVE-2024-25189- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libjwtDebian:12 |
before 1.10.2-1+deb12u1, plus listed versions 1.10.2-1 |
1.10.2-1+deb12u1 |
libjwtDebian:13 |
before 1.17.0-2 | 1.17.0-2 |
libjwtDebian:14 |
before 1.17.0-2 | 1.17.0-2 |
libjwtDebian:10 |
before 1.10.1-1+deb10u1, plus listed versions 1.10.1-1 |
1.10.1-1+deb10u1 |
libjwtUbuntu:18.04:LTS |
All versions, plus listed versions 1.8.0+dfsg-11.8.0+dfsg-21.9.0-11.9.0-1build1 |
None known |
libjwtUbuntu:20.04:LTS |
All versions, plus listed versions 1.10.2-1 |
None known |
libjwtUbuntu:22.04:LTS |
All versions, plus listed versions 1.10.2-11.10.2-1build1 |
None known |
libjwtUbuntu:24.04:LTS |
All versions, plus listed versions 1.10.2-1build11.17.0-21.17.0-2build11.17.0-2build2 |
None known |
libjwtUbuntu:25.10 |
All versions, plus listed versions 1.17.2-1 |
None known |
libjwtUbuntu:26.10 |
All versions, plus listed versions 1.17.2-1build11.17.2-1build2 |
None known |
libjwtUbuntu:26.04:LTS |
All versions, plus listed versions 1.17.2-11.17.2-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-25189 is a critical vulnerability (CVSS 9.8) in Libjwt, published February 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.95%, the 61st percentile. Fixed in libjwt 1.10.2-1+deb12u1.
References
github.com/P3ngu1nW/CVE_Request/blob/main/benmcollins%3Alibjwt.md
lists.debian.org/debian-lts-announce/2024/02/msg00009.html
nvd.nist.gov/vuln/detail/CVE-2024-25189
github.com/advisories/GHSA-m5gq-732f-j9v6
github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25189.json
security-tracker.debian.org/tracker/CVE-2024-25189