CVE-2024-25269
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an...
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
CVE-2024-25269- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2024-22605
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
EUVD-2024-22605- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-cqh8-r8g2-2v3r
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an...
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
GHSA-cqh8-r8g2-2v3r- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
CVE-2024-25269- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
CVE-2024-25269- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-25269
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
DEBIAN-CVE-2024-25269- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-25269
7.5
libheif <= 1.17.6 contains a memory leak in the function JpegEncoder::Encode. This flaw allows an attacker to cause a denial of service attack.
- Record
UBUNTU-CVE-2024-25269- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2024-25269 No score
CVE-2024-25269 in rootio-libheif - Patched by Root
Root has patched CVE-2024-25269 in the rootio-libheif package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2024-25269- Updated
- 2026-11-02
OSVUSN-7952-1 No score
libheif vulnerabilities
It was discovered that libheif did not correctly handle certain memory operations. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2024-25269)
Aldo Ristori discovered that libheif did not correctly handle certain memory operations. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2025-68431)
- Record
USN-7952-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libheifDebian:12 |
All versions, plus listed versions 1.15.1-11.15.1-1+deb12u11.16.2-11.16.2-21.16.2-3 Show 35 moreShow less1.17.0-11.17.1-11.17.4-11.17.6-11.17.6-21.17.6-31.17.6-41.18.1-11.18.1-21.18.2-11.18.2-21.19.1-11.19.1-1~bpo12+11.19.1-1~bpo12+21.19.3-11.19.3-1~bpo12+11.19.5-11.19.7-11.19.7-1~bpo12+11.19.8-11.20.1-11.20.2-11.20.2-21.21.2-11.21.2-21.21.2-31.21.2-41.23.1-11.23.2-11.23.3-11.23.4-11.23.4-1~deb13u11.23.6-11.23.6-21.23.6-2~deb13u1 |
None known |
libheifDebian:13 |
before 1.17.6-2 | 1.17.6-2 |
libheifDebian:14 |
before 1.17.6-2 | 1.17.6-2 |
rootio-libheifRoot:Debian:12 |
before 1.15.1-1+deb12u1.root.io.1 | 1.15.1-1+deb12u1.root.io.1 |
libheifUbuntu:Pro:20.04:LTS |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.0-1build11.5.1-11.5.1-1build11.6.0-11.6.1-11.6.1-1build11.6.1-1ubuntu0.1~esm1 |
1.6.1-1ubuntu0.1~esm2 |
libheifUbuntu:Pro:22.04:LTS |
before 1.12.0-2ubuntu0.1~esm2, plus listed versions 1.11.0-11.12.0-2build11.12.0-2ubuntu0.1~esm1 |
1.12.0-2ubuntu0.1~esm2 |
libheifUbuntu:24.04:LTS |
before 1.17.6-1ubuntu4.2, plus listed versions 1.16.2-2ubuntu11.17.1-1ubuntu21.17.1-1ubuntu31.17.4-1ubuntu11.17.6-1ubuntu1 Show 4 moreShow less1.17.6-1ubuntu21.17.6-1ubuntu31.17.6-1ubuntu41.17.6-1ubuntu4.1 |
1.17.6-1ubuntu4.2 |
libheifUbuntu:Pro:18.04:LTS From an advisory covering 2 CVEs |
before 1.1.0-2ubuntu0.1~esm2, plus listed versions 1.1.0-21.1.0-2ubuntu0.1~esm1 |
1.1.0-2ubuntu0.1~esm2 |
libheifUbuntu:Pro:20.04:LTS From an advisory covering 2 CVEs |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.0-1build11.5.1-11.5.1-1build11.6.0-11.6.1-11.6.1-1build11.6.1-1ubuntu0.1~esm1 |
1.6.1-1ubuntu0.1~esm2 |
libheifUbuntu:Pro:22.04:LTS From an advisory covering 2 CVEs |
before 1.12.0-2ubuntu0.1~esm2, plus listed versions 1.11.0-11.12.0-2build11.12.0-2ubuntu0.1~esm1 |
1.12.0-2ubuntu0.1~esm2 |
libheifUbuntu:24.04:LTS From an advisory covering 2 CVEs |
before 1.17.6-1ubuntu4.2, plus listed versions 1.16.2-2ubuntu11.17.1-1ubuntu21.17.1-1ubuntu31.17.4-1ubuntu11.17.6-1ubuntu1 Show 4 moreShow less1.17.6-1ubuntu21.17.6-1ubuntu31.17.6-1ubuntu41.17.6-1ubuntu4.1 |
1.17.6-1ubuntu4.2 |
libheifUbuntu:25.10 From an advisory covering 2 CVEs |
before 1.20.2-1ubuntu0.1, plus listed versions 1.19.7-11.19.8-11.20.2-1 |
1.20.2-1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-25269 is a high vulnerability (CVSS 7.5) in Libheif, published March 5, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in libheif 1.17.6-2.