CVE-2024-25723
ZenML Server Remote Privilege Escalation Vulnerability
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
CVE-2024-25723- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2024-0730
8.8
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
EUVD-2024-0730- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vf7j-cmrj-pmmm
7.1
ZenML Server Remote Privilege Escalation Vulnerability
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
GHSA-vf7j-cmrj-pmmm- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
NVD
8.8
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
CVE-2024-25723- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
OSV
8.8
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
CVE-2024-25723- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-vf7j-cmrj-pmmm
7.1
ZenML Server Remote Privilege Escalation Vulnerability
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
GHSA-vf7j-cmrj-pmmm- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVPYSEC-2026-2072
7.1
ZenML Server Remote Privilege Escalation Vulnerability
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
- Record
PYSEC-2026-2072- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zenmlPyPI |
before 0.42.2 | 0.42.2 |
zenmlPyPI |
0.43.0 to 0.43.0 | 0.43.1 |
zenmlPyPI |
0.45.0 up to 0.46.7 | 0.46.7 |
zenmlPyPI |
0.44.0 up to 0.44.4 | 0.44.4 |
zenmlPyPI |
before 0.42.2, plus listed versions 0.0.1rc10.0.1rc20.1.00.1.10.1.2 Show 45 moreShow less0.1.30.1.3rc00.1.40.1.50.10.00.11.00.12.00.13.00.13.10.13.20.2.00.2.0rc10.2.0rc20.20.00.20.0rc10.20.10.20.20.20.30.20.40.20.50.21.00.21.10.22.00.23.00.3.10.3.1rc00.3.20.3.30.3.3rc00.3.40.3.4rc00.3.50.3.5rc00.3.60.3.6.10.3.6rc00.3.70.3.7.1rc00.3.7.1rc10.3.7.1rc30.3.7.1rc40.3.7rc00.3.80.3.9rc10.3.9rc2 |
0.42.2 |
zenmlPyPI |
0.43.0 up to 0.43.1 | 0.43.1 |
zenmlPyPI |
0.45.0 up to 0.46.7, plus listed versions 0.45.10.45.20.45.30.45.40.45.50.45.60.46.00.46.1 |
0.46.7 |
zenmlPyPI |
0.44.0 up to 0.44.4, plus listed versions 0.44.10.44.20.44.3 |
0.44.4 |
zenmlPyPI |
before 0.42.2, 0.43.0 up to 0.43.1, 0.44.0 up to 0.44.4, 0.45.0 up to 0.46.7, plus listed versions 0.0.1rc10.0.1rc20.1.00.1.10.1.2 Show 45 moreShow less0.1.30.1.3rc00.1.40.1.50.10.00.11.00.12.00.13.00.13.10.13.20.2.00.2.0rc10.2.0rc20.20.00.20.0rc10.20.10.20.20.20.30.20.40.20.50.21.00.21.10.22.00.23.00.3.10.3.1rc00.3.20.3.30.3.3rc00.3.40.3.4rc00.3.50.3.5rc00.3.60.3.6.10.3.6rc00.3.70.3.7.1rc00.3.7.1rc10.3.7.1rc30.3.7.1rc40.3.7rc00.3.80.3.9rc10.3.9rc2 |
0.42.20.43.10.44.40.46.7 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | ZenML ZenML Server - Improper Authentication | |
| PoC in GitHub | david-botelho-mariano/exploit-CVE-2024-25723 | 2024-03-20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-25723 is a high vulnerability (CVSS 8.8) in Zenml, published February 27, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 70.8%, the 99th percentile. Fixed in zenml 0.42.2.
References
github.com/zenml-io/zenml
zenml.io/blog/critical-security-update-for-zenml-users
github.com/zenml-io/zenml/compare/0.44.3...0.44.4
github.com/zenml-io/zenml/compare/0.43.0...0.43.1
github.com/zenml-io/zenml/compare/0.42.1...0.42.2
nvd.nist.gov/vuln/detail/CVE-2024-25723
github.com/advisories/GHSA-vf7j-cmrj-pmmm
github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25723.json
pypi.org/project/zenml
Left out here: 107 versions. The JSON record has them.