CVE-2024-25763
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
CVE-2024-25763- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-416
- Updated
- 2026-11-02
EUVDEUVD-2024-23071
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
EUVD-2024-23071- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jrrc-pqj2-c99f
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
GHSA-jrrc-pqj2-c99f- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-416
- Updated
- 2026-11-02
NVD
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
CVE-2024-25763- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
CVE-2024-25763- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-25763
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
DEBIAN-CVE-2024-25763- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-25763
5.5
openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c.
- Record
UBUNTU-CVE-2024-25763- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVUSN-7312-1 No score
opennds vulnerability
It was discovered that openNDS did not correctly handle certain memory operations. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code.
- Record
USN-7312-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openndsDebian:12 |
All versions, plus listed versions 10.2.0+dfsg-110.3.0+dfsg-0.110.3.1+dfsg-19.10.0-1 |
None known |
openndsDebian:13 |
before 10.3.0+dfsg-0.1 | 10.3.0+dfsg-0.1 |
openndsUbuntu:Pro:24.04:LTS |
before 10.2.0+dfsg-1ubuntu0.24.04.1~esm1, plus listed versions 9.10.0-110.2.0+dfsg-110.2.0+dfsg-1build110.2.0+dfsg-1build2 |
10.2.0+dfsg-1ubuntu0.24.04.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-25763 is a medium vulnerability (CVSS 5.5) in Opennds, published February 26, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in opennds 10.3.0+dfsg-0.1.
References
github.com/LuMingYinDetect/openNDS_defects/blob/main/openNDS_detect_1.md
nvd.nist.gov/vuln/detail/CVE-2024-25763
github.com/advisories/GHSA-jrrc-pqj2-c99f
github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25763.json
security-tracker.debian.org/tracker/CVE-2024-25763
ubuntu.com/security/CVE-2024-25763
cve.org/CVERecord?id=CVE-2024-25763
ubuntu.com/security/notices/USN-7312-1