CVE-2024-27095
Decidim cross-site scripting (XSS) in the admin panel
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
Decidim cross-site scripting (XSS) in the admin panel
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
- Record
CVE-2024-27095- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2024-2253
5.4
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
- Record
EUVD-2024-2253- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-529p-jj47-w3m3
6.8
Decidim cross-site scripting (XSS) in the admin panel
Impact
The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server.
The attacker is able to change e.g. to <svg onload=alert('XSS')> if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source.
Patches
Available in versions 0.27.6 and 0.28.1.
Workarounds
Review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it.
References
OWASP ASVS v4.0.3-5.1.3
- Record
GHSA-529p-jj47-w3m3- CVSS 4.0
- 6.8 Medium
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N - CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
- Record
CVE-2024-27095- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Decidim cross-site scripting (XSS) in the admin panel
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
- Record
CVE-2024-27095- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-529p-jj47-w3m3
6.8
Decidim cross-site scripting (XSS) in the admin panel
Impact
The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server.
The attacker is able to change e.g. to <svg onload=alert('XSS')> if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source.
Patches
Available in versions 0.27.6 and 0.28.1.
Workarounds
Review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it.
References
OWASP ASVS v4.0.3-5.1.3
- Record
GHSA-529p-jj47-w3m3- CVSS 4.0
- 6.8 Medium
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N - CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
decidim-adminRubyGems |
before 0.27.6 | 0.27.6 |
decidim-adminRubyGems |
0.28.0.rc1 up to 0.28.1 | 0.28.1 |
decidim-adminRubyGems |
before 0.27.6, plus listed versions 0.0.10.0.1.alpha30.0.1.alpha40.0.1.alpha50.0.1.alpha6 Show 45 moreShow less0.0.1.alpha70.0.1.alpha80.0.1.alpha90.0.20.0.30.0.50.0.60.0.70.0.8.10.1.00.10.00.10.10.11.0.pre10.11.10.11.20.12.00.12.0.pre0.12.10.12.20.13.00.13.0.pre10.13.10.14.10.14.20.14.30.14.40.15.00.15.10.15.20.16.00.16.10.17.00.17.10.17.20.18.00.18.10.19.00.19.10.2.00.20.00.20.10.21.00.22.00.23.00.23.1 |
0.27.6 |
decidim-adminRubyGems |
0.28.0.rc1 up to 0.28.1, plus listed versions 0.28.00.28.0.rc40.28.0.rc5 |
0.28.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-27095 is a medium vulnerability (CVSS 5.4) in Decidim, published July 10, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in decidim-admin 0.27.6.
References
github.com/decidim/decidim/security/advisories/GHSA-529p-jj47-w3m3
github.com/decidim/decidim/releases/tag/v0.27.6
github.com/decidim/decidim/releases/tag/v0.28.1
nvd.nist.gov/vuln/detail/CVE-2024-27095
github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-admin/CVE-2024-27095.yml
github.com/advisories/GHSA-529p-jj47-w3m3
github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27095.json
github.com/decidim/decidim
Left out here: 72 versions. The JSON record has them.