CVE-2024-27182
Apache Linkis Basic management services: Engine material management Arbitrary file deletion vulnerability
In Apache Linkis <= 1.5.0,
Arbitrary file deletion in Basic management services on
A user with an administrator account could delete any file accessible by the Linkis system user
. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.9
In Apache Linkis <= 1.5.0,
Arbitrary file deletion in Basic management services on
A user with an administrator account could delete any file accessible by the Linkis system user
. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
CVE-2024-27182- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-552
- Updated
- 2026-11-02
CVE List
4.9
Apache Linkis Basic management services: Engine material management Arbitrary file deletion vulnerability
In Apache Linkis <= 1.5.0,
Arbitrary file deletion in Basic management services on
A user with an administrator account could delete any file accessible by the Linkis system user
. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
CVE-2024-27182- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-552
- Updated
- 2026-11-02
EUVDEUVD-2024-2603
4.9
In Apache Linkis <= 1.5.0,
Arbitrary file deletion in Basic management services on
A user with an administrator account could delete any file accessible by the Linkis system user
. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
EUVD-2024-2603- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-j6vx-r77h-44wc
7.0
Apache Linkis arbitrary file deletion vulnerability
In Apache Linkis <= 1.5.0, Arbitrary file deletion in Basic management services on a user with an administrator account could delete any file accessible by the Linkis system user. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
GHSA-j6vx-r77h-44wc- CVSS 4.0
- 7.0 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-552
- Updated
- 2026-11-02
OSV
4.9
Apache Linkis Basic management services: Engine material management Arbitrary file deletion vulnerability
In Apache Linkis <= 1.5.0,
Arbitrary file deletion in Basic management services on
A user with an administrator account could delete any file accessible by the Linkis system user
. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
CVE-2024-27182- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-552
- Updated
- 2026-11-02
OSVGHSA-j6vx-r77h-44wc
7.0
Apache Linkis arbitrary file deletion vulnerability
In Apache Linkis <= 1.5.0, Arbitrary file deletion in Basic management services on a user with an administrator account could delete any file accessible by the Linkis system user. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Record
GHSA-j6vx-r77h-44wc- CVSS 4.0
- 7.0 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-552
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.linkis:linkisMaven |
before 1.6.0 | 1.6.0 |
org.apache.linkis:linkisMaven |
before 1.6.0, plus listed versions 1.0.31.1.01.1.11.1.21.1.3 Show 6 moreShow less1.2.01.3.01.3.11.3.21.4.01.5.0 |
1.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-27182 is a medium vulnerability (CVSS 4.9) in Apache Linkis, published August 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in org.apache.linkis:linkis 1.6.0.
References
lists.apache.org/thread/2of1p433h8rbq2bx525rtftnk19oz38h
openwall.com/lists/oss-security/2024/08/02/4
nvd.nist.gov/vuln/detail/CVE-2024-27182
github.com/advisories/GHSA-j6vx-r77h-44wc
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27182.json
github.com/apache/linkis