Every CVE Search/ Get API key

CVE-2024-27292

Docassemble unauthorized access through URL manipulation

7.5 HighPublic exploitFix available

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

69.5%Up 69.4 points since Mar 1, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

Docassemble unauthorized access through URL manipulation

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Record
CVE-2024-27292
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-706
Updated
2026-11-02
EUVDEUVD-2024-0665 7.5

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Record
EUVD-2024-0665
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-jq57-3w7p-vwvv 7.5

Docassemble unauthorized access through URL manipulation

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

Record
GHSA-jq57-3w7p-vwvv
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-706
Updated
2026-11-02
NVD 7.5

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Record
CVE-2024-27292
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-706
Updated
2026-11-02
OSV 7.5

Docassemble unauthorized access through URL manipulation

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Record
CVE-2024-27292
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-706
Updated
2026-11-02
OSVGHSA-jq57-3w7p-vwvv 7.5

Docassemble unauthorized access through URL manipulation

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

Record
GHSA-jq57-3w7p-vwvv
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-706
Updated
2026-11-02
OSVPYSEC-2026-1309 7.5

Docassemble unauthorized access through URL manipulation

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

Record
PYSEC-2026-1309
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVPYSEC-2026-2453 7.5

Docassemble unauthorized access through URL manipulation

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

Record
PYSEC-2026-2453
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
docassemble-webapp
PyPI
1.4.53 up to 1.4.97
1.4.97
docassemble-base
PyPI
1.4.53 up to 1.4.97
1.4.97
docassemble-webapp
PyPI
1.4.53 up to 1.4.97, plus listed versions
1.4.541.4.551.4.561.4.571.4.58
Show 38 moreShow less
1.4.591.4.601.4.611.4.621.4.631.4.641.4.651.4.661.4.671.4.681.4.691.4.701.4.711.4.721.4.731.4.741.4.751.4.761.4.771.4.781.4.791.4.801.4.811.4.821.4.831.4.841.4.851.4.861.4.871.4.881.4.891.4.901.4.911.4.921.4.931.4.941.4.951.4.96
1.4.97
docassemble-base
PyPI
1.4.53 up to 1.4.97, plus listed versions
1.4.541.4.551.4.561.4.571.4.58
Show 38 moreShow less
1.4.591.4.601.4.611.4.621.4.631.4.641.4.651.4.661.4.671.4.681.4.691.4.701.4.711.4.721.4.731.4.741.4.751.4.761.4.771.4.781.4.791.4.801.4.811.4.821.4.831.4.841.4.851.4.861.4.871.4.881.4.891.4.901.4.911.4.921.4.931.4.941.4.951.4.96
1.4.97

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiDocassemble - Local File Inclusion
PoC in GitHubNingXin2002/Docassemble_poc2024-12-21
PoC in GitHubth3gokul/CVE-2024-272922024-07-02

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-27292 is a high vulnerability (CVSS 7.5) in Jhpyle Docassemble, published February 29, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 69.5%, the 99th percentile. Fixed in docassemble-webapp 1.4.97.

References

MoveEnter Open