Every CVE Search/ Get API key

CVE-2024-27319

Onnx Out-of-bounds Read vulnerability

4.4 MediumFix available

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
Low

Exploit likelihood

0.59%Up 0.5 points since Feb 24, 2024
90%50%10%1%

What each source reports

CVE List Score used 4.4

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
CVE-2024-27319
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2024-0125 4.4

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
EUVD-2024-0125
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-h8wv-9h96-m4hr 4.4

Onnx Out-of-bounds Read vulnerability

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
GHSA-h8wv-9h96-m4hr
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
NVD 4.4

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
CVE-2024-27319
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVAZL-34465 9.1

CVE-2024-27319 affecting package pytorch for versions less than 2.0.0-4

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
AZL-34465
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVAZL-35148 9.1

CVE-2024-27319 affecting package pytorch for versions less than 2.2.2-1

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
AZL-35148
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-05
Show 4 moreShow less
OSV 4.4

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
CVE-2024-27319
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVGHSA-h8wv-9h96-m4hr 4.4

Onnx Out-of-bounds Read vulnerability

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
GHSA-h8wv-9h96-m4hr
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVPYSEC-2024-223 9.1

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Record
PYSEC-2024-223
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13803-1 No score

libonnx-1.16.0-1.1 on GA media

These are all security issues fixed in the libonnx-1.16.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13803-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
onnx
PyPI
through 1.15.0
1.16.0
pytorch
Azure Linux:2
before 2.0.0-4
2.0.0-4
pytorch
Azure Linux:3
before 2.2.2-1
2.2.2-1
onnx
PyPI
before 1.16.0, plus listed versions
0.10.20.2.11.0.01.0.1
Show 25 moreShow less
1.1.01.1.11.1.21.10.01.10.11.10.21.11.01.12.01.13.01.13.11.14.01.14.11.15.01.2.11.2.21.2.31.3.01.4.01.4.11.5.01.6.01.7.01.8.01.8.11.9.0
1.16.0
onnx
PyPI
before 1.16.0, plus listed versions
0.10.20.2.11.0.01.0.1
Show 29 moreShow less
1.1.01.1.11.1.21.10.01.10.11.10.21.11.01.12.01.13.01.13.11.14.01.14.11.15.01.2.11.2.21.2.31.3.01.4.01.4.11.5.01.6.01.7.01.8.01.8.11.9.0v1.3.0v1.1.0v0.2v0.1
1.16.0

History

History
RecordedChangedSources
factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-27319 is a medium vulnerability (CVSS 4.4) in Linuxfoundation Onnx, published February 23, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in onnx 1.16.0.

References

Show 4 moreShow less
MoveEnter Open