Every CVE Search/ Get API key

CVE-2024-27766

An issue in MYSQL MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the...

5.7 MediumPublic exploitFix availableDisputed

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Attack profile

How easy it is to exploit

Attack vector
Physical
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
Low

Exploit likelihood

1.26%Up 1.2 points since Oct 18, 2024
90%50%10%1%

What each source reports

CVE List Score used 5.7

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
CVE-2024-27766
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2024-24959 5.7

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
EUVD-2024-24959
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-v9vv-8xcq-rpqg 5.7

An issue in MYSQL MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the...

An issue in MYSQL MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function.

Record
GHSA-v9vv-8xcq-rpqg
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Weakness
CWE-94
Updated
2026-11-02
NVD 5.7

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
CVE-2024-27766
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Weakness
CWE-94
Updated
2026-11-02
OSVUBUNTU-CVE-2024-27766 5.7

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
UBUNTU-CVE-2024-27766
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Updated
2026-11-02
OSVBIT-mariadb-2024-27766 No score

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
BIT-mariadb-2024-27766
Updated
2026-11-02
OSVBIT-mariadb-min-2024-27766 No score

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
BIT-mariadb-min-2024-27766
Updated
2026-11-02
OSVBIT-mysql-client-2024-27766 No score

An issue in MariaDB v.11.1 allows a remote attacker to execute arbitrary code via the lib_mysqludf_sys.so function. NOTE: this is disputed by the MariaDB Foundation because no privilege boundary is crossed.

Record
BIT-mysql-client-2024-27766
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mariadb
Bitnami
11.1.0 up to 11.1.5
11.1.5
mariadb-min
Bitnami
11.1.0 up to 11.4.8
11.4.8
mysql-client
Bitnami
11.1.0 up to 11.3.2
11.3.2
mysql-5.5
Ubuntu:14.04:LTS
All versions, plus listed versions
5.5.32-0ubuntu75.5.34-0ubuntu15.5.34-0ubuntu25.5.35-0ubuntu15.5.35+dfsg-1ubuntu1
Show 20 moreShow less
5.5.37-0ubuntu0.14.04.15.5.38-0ubuntu0.14.04.15.5.40-0ubuntu0.14.04.15.5.41-0ubuntu0.14.04.15.5.43-0ubuntu0.14.04.15.5.44-0ubuntu0.14.04.15.5.46-0ubuntu0.14.04.25.5.47-0ubuntu0.14.04.15.5.49-0ubuntu0.14.04.15.5.50-0ubuntu0.14.04.15.5.52-0ubuntu0.14.04.15.5.53-0ubuntu0.14.04.15.5.54-0ubuntu0.14.04.15.5.55-0ubuntu0.14.04.15.5.57-0ubuntu0.14.04.15.5.58-0ubuntu0.14.04.15.5.59-0ubuntu0.14.04.15.5.60-0ubuntu0.14.04.15.5.61-0ubuntu0.14.04.15.5.62-0ubuntu0.14.04.1
None known
mysql-5.7
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
5.7.11-0ubuntu45.7.11-0ubuntu55.7.11-0ubuntu65.7.12-0ubuntu15.7.12-0ubuntu1.1
Show 31 moreShow less
5.7.13-0ubuntu0.16.04.25.7.15-0ubuntu0.16.04.15.7.16-0ubuntu0.16.04.15.7.17-0ubuntu0.16.04.15.7.17-0ubuntu0.16.04.25.7.18-0ubuntu0.16.04.15.7.19-0ubuntu0.16.04.15.7.20-0ubuntu0.16.04.15.7.21-0ubuntu0.16.04.15.7.22-0ubuntu0.16.04.15.7.23-0ubuntu0.16.04.15.7.24-0ubuntu0.16.04.15.7.25-0ubuntu0.16.04.25.7.26-0ubuntu0.16.04.15.7.27-0ubuntu0.16.04.15.7.28-0ubuntu0.16.04.25.7.29-0ubuntu0.16.04.15.7.30-0ubuntu0.16.04.15.7.31-0ubuntu0.16.04.15.7.32-0ubuntu0.16.04.15.7.33-0ubuntu0.16.04.15.7.35-0ubuntu0.16.04.1+esm15.7.36-0ubuntu0.16.04.1+esm15.7.37-0ubuntu0.16.04.1+esm15.7.38-0ubuntu0.16.04.1+esm15.7.39-0ubuntu0.16.04.1+esm25.7.40-0ubuntu0.16.04.1+esm15.7.41-0ubuntu0.16.04.1+esm15.7.42-0ubuntu0.16.04.1+esm15.7.43-0ubuntu0.16.04.1+esm15.7.44-0ubuntu0.16.04.1+esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubHissec/Mysql_CVE-2024-277662024-10-18
PoC in GitHuby0un9eee/CVE-2024-277662026-04-09

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-27766 is a medium vulnerability (CVSS 5.7) in Mariadb, published October 17, 2024. Its validity is disputed. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in mariadb 11.1.5.

References

MoveEnter Open