Every CVE Search/ Get API key

CVE-2024-28054

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an...

7.4 HighFix available

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.83%Up 0.8 points since Mar 19, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-436
Updated
2026-11-02
EUVDEUVD-2024-25222 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
EUVD-2024-25222
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-5hmm-p9xx-45x3 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an...

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
GHSA-5hmm-p9xx-45x3
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-436
Updated
2026-11-02
NVD 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-436
Updated
2026-11-02
OSVALPINE-CVE-2024-28054 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
ALPINE-CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSV 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2024-28054 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
DEBIAN-CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2024-28054 7.4

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware.

Record
UBUNTU-CVE-2024-28054
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVMGASA-2024-0212 No score

Updated amavisd-new packages fix security vulnerability

Amavis before 2.12.3 and 2.13.x before 2.13.1, in part because of its use of MIME-tools, has an Interpretation Conflict (relative to some mail user agents) when there are multiple boundary parameters in a MIME email message. Consequently, there can be an incorrect check for banned files or malware. (CVE-2024-28054)

Record
MGASA-2024-0212
Updated
2026-11-02
OSVUSN-6790-1 No score

amavisd-new vulnerability

It was discovered that amavisd-new incorrectly handled certain MIME email messages with multiple boundary parameters. A remote attacker could possibly use this issue to bypass checks for banned files or malware.

Record
USN-6790-1
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
amavis
Alpine:v3.22
before 2.13.1-r0
2.13.1-r0
amavis
Alpine:v3.23
before 2.13.1-r0
2.13.1-r0
amavis
Alpine:v3.24
before 2.13.1-r0
2.13.1-r0
amavisd-new
Debian:12
before 1:2.13.0-3+deb12u1, plus listed versions
1:2.13.0-3
1:2.13.0-3+deb12u1
amavisd-new
Debian:13
before 1:2.13.0-5
1:2.13.0-5
amavisd-new
Debian:14
before 1:2.13.0-5
1:2.13.0-5
amavisd-new
Mageia:9
before 2.11.0-9.1.mga9
2.11.0-9.1.mga9
amavisd-new
Ubuntu:14.04:LTS
All versions, plus listed versions
1:2.7.1-2ubuntu3
None known
amavisd-new
Ubuntu:16.04:LTS
All versions, plus listed versions
1:2.7.1-2ubuntu31:2.10.1-1ubuntu11:2.10.1-2ubuntu1
None known
amavisd-new
Ubuntu:18.04:LTS
All versions, plus listed versions
1:2.10.1-4ubuntu11:2.11.0-1ubuntu11:2.11.0-1ubuntu1.1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
amavisd-new
Ubuntu:20.04:LTS
before 1:2.11.0-6.1ubuntu1.1, plus listed versions
1:2.11.0-6.1ubuntu1
1:2.11.0-6.1ubuntu1.1
amavisd-new
Ubuntu:22.04:LTS
before 1:2.12.2-1ubuntu1.1, plus listed versions
1:2.11.1-5ubuntu11:2.12.2-1ubuntu1
1:2.12.2-1ubuntu1.1
amavisd-new
Ubuntu:24.04:LTS
before 1:2.13.0-3ubuntu2, plus listed versions
1:2.13.0-3ubuntu1
1:2.13.0-3ubuntu2
amavisd-new
Ubuntu:25.10
before 1:2.13.0-6ubuntu1
1:2.13.0-6ubuntu1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-28054 is a high vulnerability (CVSS 7.4) in amavis, published March 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in amavis 2.13.1-r0.

References

Show 14 moreShow less
MoveEnter Open