Every CVE Search/ Get API key

CVE-2024-28710

LimeSurvey Cross Site Scripting vulnerability

6.1 MediumFix available

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.57%Up 0.5 points since Oct 8, 2024
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
CVE-2024-28710
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List 6.1

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
CVE-2024-28710
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-2958 6.1

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
EUVD-2024-2958
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-632q-77qj-c89q 5.1

LimeSurvey Cross Site Scripting vulnerability

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
GHSA-632q-77qj-c89q
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
CVE-2024-28710
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-632q-77qj-c89q 5.1

LimeSurvey Cross Site Scripting vulnerability

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
GHSA-632q-77qj-c89q
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVBIT-limesurvey-2024-28710 No score

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

Record
BIT-limesurvey-2024-28710
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
limesurvey/limesurvey
Packagist
before 6.5.0
6.5.0
limesurvey
Bitnami
before 6.5.0
6.5.0
limesurvey/limesurvey
Packagist
before 6.5.0, plus listed versions
1.0.42.2.52.65.2+1706062.65.3+1706072.65.4+170612
Show 45 moreShow less
2.65.5+1706132.65.6+1706152.66.6+1706192.67.0+1706222.67.1+1706262.67.2+1707282.67.3+1707282.70.0+1709212.71.0+1709252.71.1+1709272.72.0+1710102.72.1+1710122.72.2+1710172.72.3+1710202.72.4+1711102.72.5+1711212.72.6+1712072.73.0+1712192.73.1+1712203.0.0+1712223.0.0-RC.13.0.0-RC.2+1711023.0.0-RC.3+1711143.0.0-beta.1+1707203.0.0-beta.2+1708103.0.0-beta.3+1709143.0.1+1712283.0.2+1801103.0.3+1801123.0.4+1801163.0.5+1801183.1.03.1.1+1801303.10.0+1806113.11.0+1806123.12.0+1806153.12.1+1806163.12.2+1806253.12.3+1806273.13.0+1806283.13.1+1806293.13.2+1807093.14.0+1807303.14.1+1807313.14.10+180926
6.5.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-28710 is a medium vulnerability (CVSS 6.1) in Limesurvey, published October 7, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in limesurvey/limesurvey 6.5.0.

References

This page doesn't list everything

Left out here: 593 versions. The JSON record has them.

MoveEnter Open