CVE-2024-28718
OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
CVE-2024-28718- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-367
- Updated
- 2026-11-02
EUVDEUVD-2024-1238
9.8
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
EUVD-2024-1238- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jx7x-9r98-h5xr
6.3
OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
GHSA-jx7x-9r98-h5xr- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-367
- Updated
- 2026-11-02
NVD
9.8
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
CVE-2024-28718- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-367
- Updated
- 2026-11-02
OSVGHSA-jx7x-9r98-h5xr
6.3
OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
GHSA-jx7x-9r98-h5xr- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-367
- Updated
- 2026-11-02
OSVPYSEC-2026-1602
6.3
OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
PYSEC-2026-1602- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-28718
9.8
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
- Record
UBUNTU-CVE-2024-28718- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
magnumPyPI |
before 14.1.2 | 14.1.2 |
magnumPyPI |
17.0.0.0rc1 up to 17.0.2 | 17.0.2 |
magnumPyPI |
16.0.0.0rc1 up to 16.0.2 | 16.0.2 |
magnumPyPI |
15.0.0.0rc1 up to 15.0.2 | 15.0.2 |
magnumPyPI |
before 14.1.2, plus listed versions 10.0.010.0.0.0rc110.0.0.0rc210.1.011.0.0 Show 39 moreShow less11.0.0.0rc111.1.011.1.111.2.011.2.112.0.012.0.0.0rc112.0.0.0rc212.1.012.1.113.0.013.0.0.0rc113.1.013.1.114.0.014.0.0.0rc114.0.0.0rc214.1.014.1.15.0.26.3.07.0.17.0.27.1.07.2.08.0.08.0.0.0rc18.0.0.0rc28.1.08.2.08.2.19.0.09.0.0.0rc19.0.0.0rc29.1.09.2.09.3.09.4.09.4.1 |
14.1.2 |
magnumPyPI |
17.0.0.0rc1 up to 17.0.2, plus listed versions 17.0.017.0.1 |
17.0.2 |
magnumPyPI |
16.0.0.0rc1 up to 16.0.2, plus listed versions 16.0.016.0.1 |
16.0.2 |
magnumPyPI |
15.0.0.0rc1 up to 15.0.2, plus listed versions 15.0.015.0.0.0rc215.0.1 |
15.0.2 |
magnumPyPI |
before 14.1.2, 15.0.0.0rc1 up to 15.0.2, 16.0.0.0rc1 up to 16.0.2, 17.0.0.0rc1 up to 17.0.2, plus listed versions 10.0.010.0.0.0rc110.0.0.0rc210.1.011.0.0 Show 45 moreShow less11.0.0.0rc111.1.011.1.111.2.011.2.112.0.012.0.0.0rc112.0.0.0rc212.1.012.1.113.0.013.0.0.0rc113.1.013.1.114.0.014.0.0.0rc114.0.0.0rc214.1.014.1.115.0.015.0.0.0rc215.0.116.0.016.0.117.0.017.0.15.0.26.3.07.0.17.0.27.1.07.2.08.0.08.0.0.0rc18.0.0.0rc28.1.08.2.08.2.19.0.09.0.0.0rc19.0.0.0rc29.1.09.2.09.3.09.4.0 |
14.1.215.0.216.0.217.0.2 |
magnumUbuntu:16.04:LTS |
All versions, plus listed versions 1.0.0~b1-52.0.0-4ubuntu1 |
None known |
Show 7 moreShow less
| Package | Affected | Fixed |
|---|---|---|
magnumUbuntu:18.04:LTS |
All versions, plus listed versions 5.0.1-0ubuntu16.0.1-0ubuntu16.1.0-0ubuntu1 |
None known |
magnumUbuntu:20.04:LTS |
All versions, plus listed versions 9.0.0-0ubuntu110.0.0~b2~git2020020609.16ea8b63-0ubuntu110.0.0~b3~git2020032617.ce70da25-0ubuntu110.0.0~b3~git2020041013.01629398-0ubuntu110.0.0-0ubuntu0.20.04.110.0.0-0ubuntu0.20.04.210.1.0-0ubuntu1 |
None known |
magnumUbuntu:22.04:LTS |
All versions, plus listed versions 13.0.0-0ubuntu113.0.0+git2021120910.fa298eea-0ubuntu113.0.0+git2022030313.4c4bba13-0ubuntu113.0.0+git2022030313.4c4bba13-0ubuntu214.0.0-0ubuntu114.1.0-0ubuntu114.1.1-0ubuntu1 |
None known |
magnumUbuntu:24.04:LTS |
All versions, plus listed versions 17.0.0-0ubuntu117.0.1+git2023121308.537e69ae-0ubuntu117.0.1+git2024011916.f6baa6d1-0ubuntu118.0.0~rc1-0ubuntu118.0.0-0ubuntu118.0.1-0ubuntu1 |
None known |
magnumUbuntu:25.10 |
All versions, plus listed versions 20.0.0-0ubuntu120.0.0+git2025070714.cbeb6a89-0ubuntu121.0.0-0ubuntu1 |
None known |
magnumUbuntu:26.10 |
All versions, plus listed versions 22.0.0-0ubuntu122.0.0-0ubuntu222.0.0+git20260808.99.23a43e8-0ubuntu123.0.0~rc1-0ubuntu123.0.0-0ubuntu1 |
None known |
magnumUbuntu:26.04:LTS |
All versions, plus listed versions 21.0.0-0ubuntu121.0.0+git20260120.23.f2342172-0ubuntu122.0.0~rc1-0ubuntu222.0.0-0ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-28718 is a critical vulnerability (CVSS 9.8) in Openstack Magnum, published April 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in magnum 14.1.2.
References
bugs.launchpad.net/magnum/+bug/2047690
review.opendev.org/c/openstack/magnum/+/907305
gist.github.com/Fewword/f098d8d6375ac25e27b18c0e57be532f
nvd.nist.gov/vuln/detail/CVE-2024-28718
github.com/openstack/magnum/commit/272fd686d8c8bf5954e9e7d3bc991ff27e46184d
github.com/openstack/magnum/commit/312aa6a86ac8e62f6ed4f1e9473fdabbbb7a4b1e
Show 7 moreShow less
github.com/openstack/magnum/commit/883b40b5b0ecfc5f78758143c0d3c754458f12b7
github.com/openstack/magnum/commit/e79907c521149872c1b495355a3a7b3a0c7e3479
github.com/advisories/GHSA-jx7x-9r98-h5xr
github.com/openstack/magnum
pypi.org/project/magnum
ubuntu.com/security/CVE-2024-28718
cve.org/CVERecord?id=CVE-2024-28718
Left out here: 1 version. The JSON record has them.