Every CVE Search/ Get API key

CVE-2024-28754

raspap-webgui vulnerable to denial of service

7.5 HighFix available

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.86%Up 0.8 points since Mar 9, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
CVE-2024-28754
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
EUVDEUVD-2024-1014 7.5

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
EUVD-2024-1014
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-vc9f-mgxr-h32r 7.7

raspap-webgui vulnerable to denial of service

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
GHSA-vc9f-mgxr-h32r
CVSS 4.0
7.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
NVD 7.5

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
CVE-2024-28754
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
CVE-2024-28754
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-vc9f-mgxr-h32r 7.7

raspap-webgui vulnerable to denial of service

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Record
GHSA-vc9f-mgxr-h32r
CVSS 4.0
7.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
billz/raspap-webgui
Packagist
before 3.1.0
3.1.0
billz/raspap-webgui
Packagist
before 3.1.0, plus listed versions
1.02.4.12.52.5.12.5.2
Show 44 moreShow less
2.62.6-beta2.6.12.6.22.6.32.6.42.6.52.6.62.6.72.6.82.6.92.7.02.7.12.8.02.8.12.8.22.8.32.8.42.8.52.8.62.8.72.8.82.8.92.9.02.9.12.9.22.9.32.9.42.9.52.9.62.9.72.9.82.9.93.03.0-beta3.0.13.0.23.0.33.0.43.0.53.0.63.0.73.0.83.0.9
3.1.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-28754 is a high vulnerability (CVSS 7.5) in Raspap, published March 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in billz/raspap-webgui 3.1.0.

References

MoveEnter Open