CVE-2024-29415
ip SSRF improper categorization in isPublic
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918, CWE-941
- Updated
- 2026-11-02
EUVDEUVD-2024-1886
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
EUVD-2024-1886- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2p57-rm9w-gvfp
8.1
ip SSRF improper categorization in isPublic
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
GHSA-2p57-rm9w-gvfp- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
NVD
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918, CWE-941
- Updated
- 2026-11-02
OSV
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-29415
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
DEBIAN-CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVGHSA-2p57-rm9w-gvfp
8.1
ip SSRF improper categorization in isPublic
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
GHSA-2p57-rm9w-gvfp- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2024-29415
8.1
CVE-2024-29415 in ip - Patched by Root
Root has patched CVE-2024-29415 in the ip package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-06
OSVUBUNTU-CVE-2024-29415
8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally routable via isPublic. NOTE: this issue exists because of an incomplete fix for CVE-2023-42282.
- Record
UBUNTU-CVE-2024-29415- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1774657401 No score
TuxCare security update for ip (1 CVE)
TuxCare rebuilt ip to address 1 CVE. Fixed in 1.1.9-tuxcare.1.
- Record
CLSA-2026-1774657401- Updated
- 2026-11-02
OSVCLSA-2026-1792160906 No score
TuxCare security update for ip (1 CVE)
TuxCare rebuilt ip to address 1 CVE. Fixed in 2.0.1-tuxcare.1.
- Record
CLSA-2026-1792160906- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ipnpm |
through 2.0.1 | None known |
ipTuxCare:npm |
1.1.9-tuxcare.0 up to 1.1.9-tuxcare.1, plus listed versions 1.1.9 |
1.1.9-tuxcare.1 |
ipTuxCare:npm |
2.0.1-tuxcare.0 up to 2.0.1-tuxcare.1, plus listed versions 2.0.1 |
2.0.1-tuxcare.1 |
node-ipDebian:12 |
All versions, plus listed versions 2.0.0+~1.1.0-12.0.1+~1.1.3-12.0.1+~1.1.3-22.0.1+~1.1.3-3 |
None known |
node-ipDebian:13 |
before 2.0.1+~1.1.3-3 | 2.0.1+~1.1.3-3 |
node-ipDebian:14 |
before 2.0.1+~1.1.3-3 | 2.0.1+~1.1.3-3 |
ipRoot:npm |
before 1.1.9-aikido.2 | 1.1.9-aikido.22.0.1-aikido.22.0.0-aikido.31.1.5-aikido.11.1.5-aikido.21.1.8-aikido.1 |
@rootio/ipRoot:npm |
before 1.1.9-root.io.1 | 1.1.9-root.io.12.0.0-root.io.12.0.1-root.io.12.0.0-root.io.21.1.9-root.io.22.0.1-root.io.22.0.0-root.io.31.1.5-root.io.11.1.5-root.io.21.1.8-root.io.1 |
node-ipUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.1.5-11.1.5-1ubuntu0.1~esm1 |
None known |
node-ipUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.1.5-31.1.5-51.1.5-5ubuntu0.1~esm1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
node-ipUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1.1.5-51.1.5+~1.1.0-11.1.5+~1.1.0-1ubuntu0.1~esm1 |
None known |
node-ipUbuntu:24.04:LTS |
All versions, plus listed versions 2.0.0+~1.1.0-12.0.0+~1.1.0-1ubuntu1 |
None known |
node-ipUbuntu:25.10 |
All versions, plus listed versions 2.0.1+~1.1.3-12.0.1+~1.1.3-3 |
None known |
node-ipUbuntu:26.10 |
All versions, plus listed versions 2.0.1+~1.1.3-3 |
None known |
node-ipUbuntu:26.04:LTS |
All versions, plus listed versions 2.0.1+~1.1.3-3 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | felipecruz91/node-ip-vex | 2024-07-05 |
| PoC in GitHub | bybraveHQ/ip2 | 2026-07-04 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, exploits, facts | OSV | |
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-29415 is a high vulnerability (CVSS 8.1) in Fedorindutny Ip, published May 27, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.28%, the 94th percentile. Fixed in ip 1.1.9-tuxcare.1.