CVE-2024-29421
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c...
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
CVE-2024-29421- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
EUVDEUVD-2024-26427
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
EUVD-2024-26427- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fvcg-h832-4gcf
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c...
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
GHSA-fvcg-h832-4gcf- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
NVD
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
CVE-2024-29421- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-29421
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
DEBIAN-CVE-2024-29421- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-29421
6.2
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
UBUNTU-CVE-2024-29421- CVSS 3.1
- 6.2 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV No score
xmedcon 0.23.0 and fixed in v.0.24.0 is vulnerable to Buffer Overflow via libs/dicom/basic.c which allows an attacker to execute arbitrary code.
- Record
CVE-2024-29421- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xmedconDebian:12 |
before 0.23.0-gtk3+dfsg-1+deb12u1, plus listed versions 0.23.0-gtk3+dfsg-1 |
0.23.0-gtk3+dfsg-1+deb12u1 |
xmedconDebian:13 |
before 0.24.0-gtk3+dfsg-1 | 0.24.0-gtk3+dfsg-1 |
xmedconDebian:14 |
before 0.24.0-gtk3+dfsg-1 | 0.24.0-gtk3+dfsg-1 |
xmedconUbuntu:16.04:LTS |
All versions, plus listed versions 0.13.0-20.14.1-1 |
None known |
xmedconUbuntu:18.04:LTS |
All versions, plus listed versions 0.14.1-1build10.14.1-2 |
None known |
xmedconUbuntu:20.04:LTS |
All versions, plus listed versions 0.16.1+dfsg-1 |
None known |
xmedconUbuntu:22.04:LTS |
All versions, plus listed versions 0.16.3+dfsg-10.21.2+dfsg-1 |
None known |
xmedconUbuntu:24.04:LTS |
All versions, plus listed versions 0.23.0-gtk3+dfsg-10.23.0-gtk3+dfsg-1.1build10.23.0-gtk3+dfsg-1.1build20.23.0-gtk3+dfsg-1.1build3 |
None known |
xmedconUbuntu:25.10 |
All versions, plus listed versions 0.24.0-gtk3+dfsg-20.25.1-gtk3+dfsg-1 |
None known |
xmedconUbuntu:26.10 |
All versions, plus listed versions 0.25.1-gtk3+dfsg-1build10.26.1-gtk3+dfsg-1 |
None known |
xmedconUbuntu:26.04:LTS |
All versions, plus listed versions 0.25.1-gtk3+dfsg-10.25.1-gtk3+dfsg-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-29421 is a medium vulnerability (CVSS 6.2) in Xmedcon Medcon, published May 22, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.24%, the 15th percentile. Fixed in xmedcon 0.23.0-gtk3+dfsg-1+deb12u1.
References
github.com/SpikeReply/advisories/blob/530dbd7ce68600a22c47dd1bcbe360220feda1d9/cve/xmedcon/cve-2024-29421.md
nvd.nist.gov/vuln/detail/CVE-2024-29421
github.com/advisories/GHSA-fvcg-h832-4gcf
security-tracker.debian.org/tracker/CVE-2024-29421
ubuntu.com/security/CVE-2024-29421
cve.org/CVERecord?id=CVE-2024-29421