CVE-2024-29864
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into...
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
CVE-2024-29864- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
EUVDEUVD-2024-26855
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
EUVD-2024-26855- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-px53-89vh-3q6f
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into...
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
GHSA-px53-89vh-3q6f- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
NVD
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
CVE-2024-29864- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
CVE-2024-29864- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-29864
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
DEBIAN-CVE-2024-29864- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-29864
9.8
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
- Record
UBUNTU-CVE-2024-29864- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
distroboxDebian:13 |
before 1.7.0.1-1 | 1.7.0.1-1 |
distroboxDebian:14 |
before 1.7.0.1-1 | 1.7.0.1-1 |
distroboxUbuntu:24.04:LTS |
All versions, plus listed versions 1.4.2.1-11.5.0.2-11.6.0.1-11.7.0-1 |
None known |
distroboxUbuntu:25.10 |
All versions, plus listed versions 1.8.1.2-1 |
None known |
distroboxUbuntu:26.10 |
All versions, plus listed versions 1.8.2.4-11.8.2.5-1 |
None known |
distroboxUbuntu:26.04:LTS |
All versions, plus listed versions 1.8.1.2-11.8.2.2-11.8.2.4-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-29864 is a critical vulnerability (CVSS 9.8) in 89luca89 Distrobox, published March 21, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.93%, the 87th percentile. Fixed in distrobox 1.7.0.1-1.
References
github.com/89luca89/distrobox/commit/82a69f0a234e73e447d0ea8c8b3443b84fd31944
github.com/89luca89/distrobox/issues/1275
nvd.nist.gov/vuln/detail/CVE-2024-29864
github.com/advisories/GHSA-px53-89vh-3q6f
github.com/CVEProject/cvelistV5/tree/main/cves/2024/29xxx/CVE-2024-29864.json
security-tracker.debian.org/tracker/CVE-2024-29864
ubuntu.com/security/CVE-2024-29864
cve.org/CVERecord?id=CVE-2024-29864