CVE-2024-30187
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
CVE-2024-30187- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-281
- Updated
- 2026-11-02
EUVDEUVD-2024-28120
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
EUVD-2024-28120- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mxmg-v768-hh7w
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
GHSA-mxmg-v768-hh7w- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-281
- Updated
- 2026-11-02
NVD
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
CVE-2024-30187- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-281
- Updated
- 2026-11-02
OSV
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
CVE-2024-30187- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-30187
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
DEBIAN-CVE-2024-30187- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-30187
5.3
Anope before 2.0.15 does not prevent resetting the password of a suspended account.
- Record
UBUNTU-CVE-2024-30187- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUSN-6761-1 No score
anope vulnerability
It was discovered that Anope did not properly process credentials for suspended accounts. An attacker could possibly use this issue to normally login to the platform as a suspended user after changing their password.
- Record
USN-6761-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
anopeDebian:12 |
All versions, plus listed versions 2.0.12-12.0.15-12.0.17-12.0.17-1.1 |
None known |
anopeDebian:13 |
before 2.0.15-1 | 2.0.15-1 |
anopeDebian:14 |
before 2.0.15-1 | 2.0.15-1 |
anopeUbuntu:Pro:16.04:LTS |
before 2.0.3-1ubuntu0.1~esm1, plus listed versions 2.0.2-22.0.3-12.0.3-1build12.0.3-1build2 |
2.0.3-1ubuntu0.1~esm1 |
anopeUbuntu:Pro:18.04:LTS |
before 2.0.4-2ubuntu0.1~esm1, plus listed versions 2.0.4-2 |
2.0.4-2ubuntu0.1~esm1 |
anopeUbuntu:20.04:LTS |
before 2.0.6-1ubuntu0.1, plus listed versions 2.0.6-1build22.0.6-1build3 |
2.0.6-1ubuntu0.1 |
anopeUbuntu:22.04:LTS |
before 2.0.9-1ubuntu0.1, plus listed versions 2.0.9-1build12.0.9-1build2 |
2.0.9-1ubuntu0.1 |
anopeUbuntu:24.04:LTS |
before 2.0.12-1ubuntu1, plus listed versions 2.0.12-12.0.12-1build12.0.12-1build2 |
2.0.12-1ubuntu1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-30187 is a medium vulnerability (CVSS 5.3) in Anope, published March 25, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in anope 2.0.15-1.
References
github.com/anope/anope/issues/351
github.com/anope/anope/commit/2b7872139c40ea5b0ca96c1d6595b7d5f9fa60a5
nvd.nist.gov/vuln/detail/CVE-2024-30187
github.com/advisories/GHSA-mxmg-v768-hh7w
github.com/CVEProject/cvelistV5/tree/main/cves/2024/30xxx/CVE-2024-30187.json
security-tracker.debian.org/tracker/CVE-2024-30187
ubuntu.com/security/CVE-2024-30187
cve.org/CVERecord?id=CVE-2024-30187
ubuntu.com/security/notices/USN-6761-1