CVE-2024-30917
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause...
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
CVE-2024-30917- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-229, CWE-922
- Updated
- 2026-11-02
EUVDEUVD-2024-28835
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
EUVD-2024-28835- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8p3v-87jv-mp95
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause...
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
GHSA-8p3v-87jv-mp95- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-229
- Updated
- 2026-11-02
NVD
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
CVE-2024-30917- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-229, CWE-922
- Updated
- 2026-11-02
OSV
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
CVE-2024-30917- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-30917
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
DEBIAN-CVE-2024-30917- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-30917
5.5
An issue was discovered in eProsima FastDDS v.2.14.0 and before, allows a local attacker to cause a denial of service (DoS) and obtain sensitive information via a crafted history_depth parameter in DurabilityService QoS component.
- Record
UBUNTU-CVE-2024-30917- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fastddsDebian:12 |
All versions, plus listed versions 2.10.1+ds-12.10.1+ds-22.10.1+ds-32.11.2+ds-12.11.2+ds-2 Show 27 moreShow less2.11.2+ds-32.11.2+ds-42.11.2+ds-52.11.2+ds-62.11.2+ds-6.12.11.2+ds-6.1~exp12.14.0+ds-12.14.0+ds-22.14.0+ds-32.14.0+ds-42.14.1+ds-12.14.2+ds-12.14.3+ds-12.9.1+ds-12.9.1+ds-1+deb12u12.9.1+ds-1+deb12u23.0.0+ds-13.0.0+ds-23.0.0+ds-33.0.1+ds-13.1.0+ds-13.1.0+ds-23.1.2+ds-13.3.0+ds-13.3.0+ds-23.3.0+ds-33.6.1+ds-1 |
None known |
fastddsDebian:13 |
before 2.14.1+ds-1 | 2.14.1+ds-1 |
fastddsUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 2.1.0+ds-92.4.1+ds-12.5.0+ds-32.5.0+ds-3ubuntu0.1~esm1 |
None known |
fastddsUbuntu:24.04:LTS |
All versions, plus listed versions 2.10.1+ds-32.11.2+ds-62.11.2+ds-6ubuntu12.11.2+ds-6.1build22.11.2+ds-6.1build3 |
None known |
fastddsUbuntu:25.10 |
All versions, plus listed versions 3.1.2+ds-13.1.2+ds-1build1 |
None known |
fastddsUbuntu:26.10 |
All versions, plus listed versions 3.3.0+ds-3ubuntu13.3.0+ds-3ubuntu3 |
None known |
fastddsUbuntu:26.04:LTS |
All versions, plus listed versions 3.1.2+ds-1build13.3.0+ds-3ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-30917 is a medium vulnerability (CVSS 5.5) in Eprosima Fast Dds, published April 11, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.22%, the 12th percentile. Fixed in fastdds 2.14.1+ds-1.
References
github.com/eProsima/Fast-DDS/issues/4609
nvd.nist.gov/vuln/detail/CVE-2024-30917
github.com/advisories/GHSA-8p3v-87jv-mp95
github.com/CVEProject/cvelistV5/tree/main/cves/2024/30xxx/CVE-2024-30917.json
security-tracker.debian.org/tracker/CVE-2024-30917
ubuntu.com/security/CVE-2024-30917
cve.org/CVERecord?id=CVE-2024-30917