Every CVE Search/ Get API key

CVE-2024-31031

An issue in `coap_pdu.c` in libcoap 4.3.4 allows attackers to cause undefined behavior via a...

7.5 HighFix available

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.87%Up 0.8 points since Apr 18, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
CVE-2024-31031
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2024-28949 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
EUVD-2024-28949
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-8hrj-6457-w65j 7.5

An issue in `coap_pdu.c` in libcoap 4.3.4 allows attackers to cause undefined behavior via a...

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
GHSA-8hrj-6457-w65j
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
CVE-2024-31031
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
CVE-2024-31031
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2024-31031 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
DEBIAN-CVE-2024-31031
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-31031 7.5

An issue in coap_pdu.c in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.

Record
UBUNTU-CVE-2024-31031
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcoap3
Debian:12
All versions, plus listed versions
4.3.1-14.3.1-24.3.3-14.3.4-14.3.4-1.1
Show 5 moreShow less
4.3.4-1.1~exp14.3.5-14.3.5-24.3.5-34.3.5-4
None known
libcoap3
Debian:13
before 4.3.4-1.1+deb13u1, plus listed versions
4.3.4-1.1
4.3.4-1.1+deb13u1
libcoap3
Debian:14
before 4.3.5-1, plus listed versions
4.3.4-1.1
4.3.5-1
libcoap
Ubuntu:18.04:LTS
All versions, plus listed versions
4.1.2-1
None known
libcoap2
Ubuntu:20.04:LTS
All versions, plus listed versions
4.2.0-24.2.1-1
None known
libcoap2
Ubuntu:22.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1build1
None known
libcoap3
Ubuntu:22.04:LTS
All versions, plus listed versions
4.3.0-24.3.0-2build1
None known
libcoap3
Ubuntu:24.04:LTS
All versions, plus listed versions
4.3.1-24.3.3-14.3.4-14.3.4-1.1build24.3.4-1.1build34.3.4-1.1build4
None known
libcoap3
Ubuntu:25.10
All versions, plus listed versions
4.3.4-1.1build4
None known
libcoap3
Ubuntu:26.10
All versions, plus listed versions
4.3.5-24.3.5-34.3.5-44.3.5-4ubuntu1
None known
libcoap3
Ubuntu:26.04:LTS
All versions, plus listed versions
4.3.4-1.1build44.3.5-14.3.5-2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-31031 is a high vulnerability (CVSS 7.5) in Libcoap, published April 17, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in libcoap3 4.3.4-1.1+deb13u1.

References

Show 5 moreShow less
MoveEnter Open