CVE-2024-31837
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a...
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
CVE-2024-31837- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-134
- Updated
- 2026-11-02
EUVDEUVD-2024-29708
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
EUVD-2024-29708- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9x99-qq28-ff9g
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a...
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
GHSA-9x99-qq28-ff9g- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-134
- Updated
- 2026-11-02
NVD
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
CVE-2024-31837- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-134
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-31837
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
DEBIAN-CVE-2024-31837- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-31837
8.4
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
UBUNTU-CVE-2024-31837- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-04
OSV No score
DMitry (Deepmagic Information Gathering Tool) 1.3a has a format-string vulnerability, with a threat model similar to CVE-2017-7938.
- Record
CVE-2024-31837- Updated
- 2026-11-02
OSVUSN-8980-1 No score
dmitry vulnerabilities
It was discovered that DMitry incorrectly handled long arguments, leading to a stack-based buffer overflow. An attacker could possibly use this issue to cause DMitry to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-7938)
It was discovered that DMitry incorrectly handled long lines in WHOIS responses, leading to a stack-based buffer overflow. A remote attacker could possibly use this issue to cause DMitry to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-14931)
It was discovered that DMitry contained a format string vulnerability. An attacker could possibly use this issue to cause DMitry to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2024-31837)
- Record
USN-8980-1- Updated
- 2026-11-04
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dmitryDebian:12 |
before 1.3a-1.2+deb12u1, plus listed versions 1.3a-1.2 |
1.3a-1.2+deb12u1 |
dmitryDebian:13 |
before 1.3a-5 | 1.3a-5 |
dmitryDebian:14 |
before 1.3a-5 | 1.3a-5 |
dmitryDebian:11 From an advisory covering 3 CVEs |
before 1.3a-1.1+deb11u1, plus listed versions 1.3a-1.1 |
1.3a-1.1+deb11u1 |
dmitryUbuntu:Pro:16.04:LTS |
before 1.3a-1ubuntu0.16.04.1~esm1, plus listed versions 1.3a-1 |
1.3a-1ubuntu0.16.04.1~esm1 |
dmitryUbuntu:Pro:18.04:LTS |
before 1.3a-1ubuntu0.18.04.1~esm1, plus listed versions 1.3a-11.3a-1build1 |
1.3a-1ubuntu0.18.04.1~esm1 |
dmitryUbuntu:Pro:20.04:LTS |
before 1.3a-1ubuntu0.20.04.1~esm1, plus listed versions 1.3a-1build1 |
1.3a-1ubuntu0.20.04.1~esm1 |
dmitryUbuntu:Pro:22.04:LTS |
before 1.3a-1.2ubuntu0.22.04.1~esm1, plus listed versions 1.3a-1.11.3a-1.2 |
1.3a-1.2ubuntu0.22.04.1~esm1 |
dmitryUbuntu:Pro:24.04:LTS |
before 1.3a-3ubuntu0.1~esm1, plus listed versions 1.3a-21.3a-3 |
1.3a-3ubuntu0.1~esm1 |
dmitryUbuntu:25.10 |
All versions, plus listed versions 1.3a-6 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
dmitryUbuntu:Pro:16.04:LTS From an advisory covering 3 CVEs |
before 1.3a-1ubuntu0.16.04.1~esm1, plus listed versions 1.3a-1 |
1.3a-1ubuntu0.16.04.1~esm1 |
dmitryUbuntu:Pro:18.04:LTS From an advisory covering 3 CVEs |
before 1.3a-1ubuntu0.18.04.1~esm1, plus listed versions 1.3a-11.3a-1build1 |
1.3a-1ubuntu0.18.04.1~esm1 |
dmitryUbuntu:Pro:20.04:LTS From an advisory covering 3 CVEs |
before 1.3a-1ubuntu0.20.04.1~esm1, plus listed versions 1.3a-1build1 |
1.3a-1ubuntu0.20.04.1~esm1 |
dmitryUbuntu:Pro:22.04:LTS From an advisory covering 3 CVEs |
before 1.3a-1.2ubuntu0.22.04.1~esm1, plus listed versions 1.3a-1.11.3a-1.2 |
1.3a-1.2ubuntu0.22.04.1~esm1 |
dmitryUbuntu:Pro:24.04:LTS From an advisory covering 3 CVEs |
before 1.3a-3ubuntu0.1~esm1, plus listed versions 1.3a-21.3a-3 |
1.3a-3ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| affected, aliases, references | OSV | |
| affected, facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-31837 is a high vulnerability (CVSS 8.4) in dmitry, published April 30, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in dmitry 1.3a-1.2+deb12u1.