CVE-2024-31860
Apache Zeppelin: Path traversal vulnerability
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Apache Zeppelin: Path traversal vulnerability
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
CVE-2024-31860- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2024-1201
6.5
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
EUVD-2024-1201- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-g64r-xf39-q4p5
5.3
Apache Zeppelin Path Traversal vulnerability
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators (e.g ..), attackers can see the contents for any files in the filesystem that the server account can access.
This issue affects Apache Zeppelin from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
GHSA-g64r-xf39-q4p5- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-20, CWE-22
- Updated
- 2026-11-02
NVD
6.5
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
CVE-2024-31860- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
6.5
Apache Zeppelin: Path traversal vulnerability
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
CVE-2024-31860- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-g64r-xf39-q4p5
5.3
Apache Zeppelin Path Traversal vulnerability
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators (e.g ..), attackers can see the contents for any files in the filesystem that the server account can access.
This issue affects Apache Zeppelin from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
- Record
GHSA-g64r-xf39-q4p5- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-20, CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.zeppelin:zeppelin-serverMaven |
0.9.0 up to 0.11.0 | 0.11.0 |
org.apache.zeppelin:zeppelin-serverMaven |
0.9.0 up to 0.11.0, plus listed versions 0.10.00.10.10.9.0-preview10.9.0-preview2 |
0.11.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-31860 is a medium vulnerability (CVSS 6.5) in Apache Zeppelin, published April 9, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.39%, the 72nd percentile. Fixed in org.apache.zeppelin:zeppelin-server 0.11.0.
References
github.com/apache/zeppelin/pull/4632
lists.apache.org/thread/c0zfjnow3oc3dzc8w5rbkzj8lqj5jm5x
openwall.com/lists/oss-security/2024/04/09/2
nvd.nist.gov/vuln/detail/CVE-2024-31860
github.com/apache/zeppelin/commit/f025a697c1d1d0264064d5adf6cb0b20d85041b6
github.com/advisories/GHSA-g64r-xf39-q4p5
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31860.json
github.com/apache/zeppelin