Every CVE Search/ Get API key

CVE-2024-3209

UPX bele.h get_ne64 heap-based overflow

5.5 MediumFix available

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

1.22%Up 1.2 points since Apr 3, 2024
90%50%10%1%

What each source reports

CVE List Score used 5.5

UPX bele.h get_ne64 heap-based overflow

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
CVE-2024-3209
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
5.5 MediumCVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
5.2 AV:A/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2024-31801 5.5

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
EUVD-2024-31801
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-97xg-px2h-jvxp 5.5

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects...

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
GHSA-97xg-px2h-jvxp
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-122
Updated
2026-11-02
NVD 5.5

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
CVE-2024-3209
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
5.2 MediumAV:A/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-122
Updated
2026-11-02
OSV 5.5

UPX bele.h get_ne64 heap-based overflow

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
CVE-2024-3209
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-122
Updated
2026-11-02
OSVDEBIAN-CVE-2024-3209 9.8

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
DEBIAN-CVE-2024-3209
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-3209 5.5

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
UBUNTU-CVE-2024-3209
CVSS 3.1
5.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2024-0134 No score

Updated upx packages fix security vulnerability

A vulnerability was found in UPX up to 4.2.2. It has been rated as critical. This issue affects the function get_ne64 of the file bele.h. The manipulation leads to heap-based buffer overflow. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-259055. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Record
MGASA-2024-0134
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
upx-ucl
Debian:13
before 4.2.4-1
4.2.4-1
upx-ucl
Debian:14
before 4.2.4-1
4.2.4-1
upx
Mageia:9
before 4.2.3-1.mga9
4.2.3-1.mga9
upx-ucl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.91-1
None known
upx-ucl
Ubuntu:18.04:LTS
All versions, plus listed versions
3.94-23.94-33.94-4
None known
upx-ucl
Ubuntu:20.04:LTS
All versions, plus listed versions
3.95-23.95-2build1
None known
upx-ucl
Ubuntu:22.04:LTS
All versions, plus listed versions
3.96-23.96-3
None known
upx-ucl
Ubuntu:24.04:LTS
All versions, plus listed versions
3.96-34.2.2-3
None known
upx-ucl
Ubuntu:25.10
All versions, plus listed versions
4.2.4-14.2.4-1.1
None known
upx-ucl
Ubuntu:26.10
All versions, plus listed versions
4.2.4-1.1build1
None known
upx-ucl
Ubuntu:26.04:LTS
All versions, plus listed versions
4.2.4-1.14.2.4-1.1build1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-3209 is a medium vulnerability (CVSS 5.5) in Upx, published April 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.22%, the 68th percentile. Fixed in upx-ucl 4.2.4-1.

References

Show 9 moreShow less
MoveEnter Open