Every CVE Search/ Get API key

CVE-2024-32469

Decidim has cross-site scripting (XSS) in the pagination

7.1 HighFix available

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page. This vulnerability is fixed in 0.27.6 and 0.28.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

0.42%Up 0.4 points since Jul 11, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.1

Decidim has cross-site scripting (XSS) in the pagination

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page. This vulnerability is fixed in 0.27.6 and 0.28.1.

Record
CVE-2024-32469
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-2286 7.1

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page. This vulnerability is fixed in 0.27.6 and 0.28.1.

Record
EUVD-2024-2286
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-7cx8-44pc-xv3q 6.3

Decidim cross-site scripting (XSS) in the pagination

Impact

The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page.

Patches

Not available

Workarounds

Not available

References

OWASP ASVS v4.0.3-5.1.3

Credits

This issue was discovered in a security audit organized by the mitgestalten Partizipationsbüro and funded by netidee against Decidim done during April 2024. The security audit was implemented by AIT Austrian Institute of Technology GmbH,

Record
GHSA-7cx8-44pc-xv3q
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 7.1

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page. This vulnerability is fixed in 0.27.6 and 0.28.1.

Record
CVE-2024-32469
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 7.1

Decidim has cross-site scripting (XSS) in the pagination

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page. This vulnerability is fixed in 0.27.6 and 0.28.1.

Record
CVE-2024-32469
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-7cx8-44pc-xv3q 6.3

Decidim cross-site scripting (XSS) in the pagination

Impact

The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter per_page.

Patches

Not available

Workarounds

Not available

References

OWASP ASVS v4.0.3-5.1.3

Credits

This issue was discovered in a security audit organized by the mitgestalten Partizipationsbüro and funded by netidee against Decidim done during April 2024. The security audit was implemented by AIT Austrian Institute of Technology GmbH,

Record
GHSA-7cx8-44pc-xv3q
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N
CVSS 3.1
7.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
decidim
RubyGems
before 0.27.6
0.27.6
decidim
RubyGems
0.28.0.rc1 up to 0.28.1
0.28.1
decidim
RubyGems
before 0.27.6, plus listed versions
0.0.10.0.1.alpha10.0.1.alpha20.0.1.alpha30.0.1.alpha4
Show 45 moreShow less
0.0.1.alpha50.0.1.alpha60.0.1.alpha70.0.1.alpha80.0.1.alpha90.0.20.0.30.0.40.0.50.0.60.0.70.0.8.10.1.00.10.00.10.10.11.0.pre10.11.10.11.20.12.00.12.0.pre0.12.10.12.20.13.00.13.0.pre10.13.10.14.10.14.20.14.30.14.40.15.00.15.10.15.20.16.00.16.10.17.00.17.10.17.20.18.00.18.10.19.00.19.10.2.00.20.00.20.10.21.0
0.27.6
decidim
RubyGems
0.28.0.rc1 up to 0.28.1, plus listed versions
0.28.00.28.0.rc40.28.0.rc5
0.28.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-32469 is a high vulnerability (CVSS 7.1) in Decidim, published July 10, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in decidim 0.27.6.

References

This page doesn't list everything

Left out here: 74 versions. The JSON record has them.

MoveEnter Open