Every CVE Search/ Get API key

CVE-2024-33998

moodle: stored XSS via user's name on participants page when opening some options

5.4 MediumFix available

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.37%Up 0.3 points since Jun 1, 2024
90%50%10%1%

What each source reports

CVE List Score used 5.4

moodle: stored XSS via user's name on participants page when opening some options

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
CVE-2024-33998
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-1870 5.4

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
EUVD-2024-1870
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-xqhh-253w-4q5f 5.4

Moodle Cross-site Scripting (XSS)

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
GHSA-xqhh-253w-4q5f
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
CVE-2024-33998
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

moodle: stored XSS via user's name on participants page when opening some options

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
CVE-2024-33998
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-xqhh-253w-4q5f 5.4

Moodle Cross-site Scripting (XSS)

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
GHSA-xqhh-253w-4q5f
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2024-33998 5.4

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
UBUNTU-CVE-2024-33998
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVBIT-moodle-2024-33998 No score

moodle: stored XSS via user's name on participants page when opening some options

Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.

Record
BIT-moodle-2024-33998
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
4.3.0 up to 4.3.4
4.3.4
moodle/moodle
Packagist
4.2.0 up to 4.2.7
4.2.7
moodle/moodle
Packagist
before 4.1.10
4.1.10
moodle
Bitnami
before 4.1.10, 4.2.0 up to 4.2.7, 4.3.0 up to 4.3.4
4.1.104.2.74.3.4
moodle/moodle
Packagist
4.3.0 up to 4.3.4, plus listed versions
v4.3.0v4.3.1v4.3.2v4.3.3
4.3.4
moodle/moodle
Packagist
4.2.0 up to 4.2.7, plus listed versions
v4.2.0v4.2.1v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6
4.2.7
moodle/moodle
Packagist
before 4.1.10, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.10
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-33998 is a medium vulnerability (CVSS 5.4) in Moodle, published May 31, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 31st percentile. Fixed in moodle/moodle 4.3.4.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 292 versions. The JSON record has them.

MoveEnter Open