Every CVE Search/ Get API key

CVE-2024-34001

moodle: CSRF risk in admin preset tool management of presets

8.4 HighFix available

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.40%Up 0.4 points since Jun 1, 2024
90%50%10%1%

What each source reports

CVE List Score used 8.4

moodle: CSRF risk in admin preset tool management of presets

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
CVE-2024-34001
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2024-1630 8.4

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
EUVD-2024-1630
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-gq9f-8rj4-w7jc 8.4

Moodle CSRF risk in admin preset tool management of presets

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
GHSA-gq9f-8rj4-w7jc
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
NVD 8.4

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
CVE-2024-34001
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSV 8.4

moodle: CSRF risk in admin preset tool management of presets

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
CVE-2024-34001
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-gq9f-8rj4-w7jc 8.4

Moodle CSRF risk in admin preset tool management of presets

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
GHSA-gq9f-8rj4-w7jc
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2024-34001 8.4

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
UBUNTU-CVE-2024-34001
CVSS 3.1
8.4 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-moodle-2024-34001 No score

moodle: CSRF risk in admin preset tool management of presets

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Record
BIT-moodle-2024-34001
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
4.3.0 up to 4.3.4
4.3.4
moodle/moodle
Packagist
4.2.0 up to 4.2.7
4.2.7
moodle/moodle
Packagist
before 4.1.10
4.1.10
moodle
Bitnami
before 4.1.10, 4.2.0 up to 4.2.7, 4.3.0 up to 4.3.4
4.1.104.2.74.3.4
moodle/moodle
Packagist
4.3.0 up to 4.3.4, plus listed versions
v4.3.0v4.3.1v4.3.2v4.3.3
4.3.4
moodle/moodle
Packagist
4.2.0 up to 4.2.7, plus listed versions
v4.2.0v4.2.1v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6
4.2.7
moodle/moodle
Packagist
before 4.1.10, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.10
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-34001 is a high vulnerability (CVSS 8.4) in Moodle, published May 31, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in moodle/moodle 4.3.4.

References

This page doesn't list everything

Left out here: 292 versions. The JSON record has them.

MoveEnter Open