Every CVE Search/ Get API key

CVE-2024-36315

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass...

5.7 MediumFix available

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.14%Up 0.1 points since May 13, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.7

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Record
CVE-2024-36315
CVSS 4.0
5.7 MediumCVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-693
Updated
2026-11-02
EUVDEUVD-2024-55576 5.7

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Record
EUVD-2024-55576
CVSS 4.0
5.7 MediumCVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-48h8-ccw7-958p 5.7

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass...

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Record
GHSA-48h8-ccw7-958p
CVSS 4.0
5.7 MediumCVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-693
Updated
2026-11-02
NVD 5.7

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Record
CVE-2024-36315
CVSS 4.0
5.7 MediumCVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-693
Updated
2026-11-02
OSVUBUNTU-CVE-2024-36315 5.7

Improper enforcement of the LFENCE serialization property may allow an attacker to bypass speculation barriers and potentially disclose sensitive information, potentially resulting in loss of confidentiality.

Record
UBUNTU-CVE-2024-36315
CVSS 4.0
5.7 MediumCVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02

Affected products

Show 5 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
amd64-microcode
Ubuntu:14.04:LTS
All versions, plus listed versions
1.20120910-32.20131007.1+really20130710.13.20180524.1~ubuntu0.14.04.13.20180524.1~ubuntu0.14.04.2+really20130710.13.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1
None known
amd64-microcode
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.20141028.12.20160316.13.20180524.1~ubuntu0.16.04.13.20180524.1~ubuntu0.16.04.23.20191021.1ubuntu0.16.04.1
Show 4 moreShow less
3.20191021.1+really3.20180524.1~ubuntu0.16.04.23.20191021.1+really3.20180524.1~ubuntu0.16.04.2+esm13.20191021.1+really3.20180524.1~ubuntu0.16.04.2+esm23.20191021.1+really3.20180524.1~ubuntu0.16.04.2+esm3
None known
amd64-microcode
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.20160316.33.20171205.13.20180524.1~ubuntu0.18.04.13.20180524.1~ubuntu0.18.04.23.20191021.1ubuntu0.18.04.2
Show 4 moreShow less
3.20191021.1+really3.20181128.1~ubuntu0.18.04.13.20191021.1+really3.20181128.1~ubuntu0.18.04.1+esm13.20191021.1+really3.20181128.1~ubuntu0.18.04.1+esm23.20191021.1+really3.20181128.1~ubuntu0.18.04.1+esm3
None known
amd64-microcode
Ubuntu:20.04:LTS
All versions, plus listed versions
3.20181128.1ubuntu23.20191021.1ubuntu13.20191218.1ubuntu13.20191218.1ubuntu1.13.20191218.1ubuntu1.23.20191218.1ubuntu1.3
None known
amd64-microcode
Ubuntu:22.04:LTS
All versions, plus listed versions
3.20191218.1ubuntu23.20191218.1ubuntu2.13.20191218.1ubuntu2.23.20191218.1ubuntu2.3
None known
amd64-microcode
Ubuntu:24.04:LTS
before 3.20251202.1ubuntu0.24.04.1, plus listed versions
3.20230808.1.1ubuntu13.20231019.1ubuntu13.20231019.1ubuntu23.20231019.1ubuntu2.13.20250311.1ubuntu0.24.04.1
3.20251202.1ubuntu0.24.04.1
amd64-microcode
Ubuntu:25.10
before 3.20251202.1ubuntu0.25.10.1, plus listed versions
3.20240820.1ubuntu13.20250311.1ubuntu13.20250708.1ubuntu1
3.20251202.1ubuntu0.25.10.1
amd64-microcode
Ubuntu:26.04:LTS
before 3.20251202.1ubuntu1, plus listed versions
3.20250708.1ubuntu13.20250708.1ubuntu2
3.20251202.1ubuntu1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-36315 is a medium vulnerability (CVSS 5.7) in Amd Epyc™ 8004 Series Processors, published May 13, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 2nd percentile. Fixed in amd64-microcode 3.20251202.1ubuntu0.24.04.1.

References

MoveEnter Open