CVE-2024-36465
SQL injection in Zabbix API
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.6
SQL injection in Zabbix API
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
CVE-2024-36465- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2025-9502
8.6
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
EUVD-2025-9502- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9g97-3vch-5xc2
8.6
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in...
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
GHSA-9g97-3vch-5xc2- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
8.6
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
CVE-2024-36465- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
8.8
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
CVE-2024-36465- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-36465
8.8
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
DEBIAN-CVE-2024-36465- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-36465
8.6
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
- Record
UBUNTU-CVE-2024-36465- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zabbixDebian:13 |
before 1:7.0.9+dfsg-1 | 1:7.0.9+dfsg-1 |
zabbixDebian:14 |
before 1:7.0.9+dfsg-1 | 1:7.0.9+dfsg-1 |
zabbixUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu1 Show 4 moreShow less1:2.2.2+dfsg-1ubuntu1+esm11:2.2.2+dfsg-1ubuntu1+esm31:2.2.2+dfsg-1ubuntu1+esm41:2.2.2+dfsg-1ubuntu1+esm5 |
None known |
zabbixUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.1 Show 4 moreShow less1:2.4.7+dfsg-2ubuntu2.1+esm11:2.4.7+dfsg-2ubuntu2.1+esm21:2.4.7+dfsg-2ubuntu2.1+esm31:2.4.7+dfsg-2ubuntu2.1+esm4 |
None known |
zabbixUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm11:3.0.12+dfsg-1ubuntu0.1~esm21:3.0.12+dfsg-1ubuntu0.1~esm31:3.0.12+dfsg-1ubuntu0.1~esm4 |
None known |
zabbixUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-1 Show 5 moreShow less1:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-11:4.0.17+dfsg-1ubuntu0.1~esm11:4.0.17+dfsg-1ubuntu0.1~esm2 |
None known |
zabbixUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1:5.0.8+dfsg-1build11:5.0.14+dfsg-11:5.0.17+dfsg-11:5.0.17+dfsg-1ubuntu0.1~esm1 |
None known |
zabbixUbuntu:25.10 |
All versions, plus listed versions 1:7.0.10+dfsg-21:7.0.10+dfsg-2build1 |
None known |
zabbixUbuntu:26.10 |
All versions, plus listed versions 1:7.0.22+dfsg-11:7.0.22+dfsg-1.11:7.0.22+dfsg-1.1build11:7.0.22+dfsg-1.1build21:7.0.27+dfsg-1 |
None known |
zabbixUbuntu:26.04:LTS |
All versions, plus listed versions 1:7.0.10+dfsg-2build11:7.0.22+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-36465 is a high vulnerability (CVSS 8.6) in Zabbix, published April 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 39.9%, the 98th percentile. Fixed in zabbix 1:7.0.9+dfsg-1.